[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dchroot with sid

On Fri, 2006-06-30 at 19:16 +0100, Dave Ewart wrote:
> On Friday, 30.06.2006 at 12:39 -0500, Owen Heisler wrote:
> > I have a 32-bit sid chroot installed at /var/chroot/unstable-ia32 on my
> > amd64 Sarge system.
> > 
> > But I get this error with any command:
> > 
> > # dchroot -d -c unstable ls
> > (unstable) ls
> > /bin/ls: /bin/ls: cannot execute binary file
> > dchroot: Child exited non-zero.
> > dchroot: Operation failed.
> > 
> > I used the amd64 howto to do this, and started with a sarge
> > installation, then upgraded to etch, then sid.  At etch, I started
> > getting this error.
> > 
> > I have copied /etc/passwd, /etc/shadow, and /etc/group into the chroot.
> > 
> > I have modified /etc/fstab (on the "host" 64-bit) to
> > include /var/chroot/unstable-ia32/home, tmp, and proc.
> > 
> > Any suggestions?
> Looks like you've hit
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=360604
> Read the report for some tips.  As a further note, you've probably find
> that you *will* be able to run *scripts*, if not executables, so you can
> write a small wrapper round your executables as a temporary workaround.

Okay, here is something from that page:
As a workarround, you can set the SU_NO_SHELL_ARGS environment variable
before calling dchroot, or execute
        dchroot -- -c "command"
instead of
        dchroot -- command

How do I set the SU_NO_SHELL_ARGS env var?  "set SU_NO_SHELL_ARGS=1" doesn't help.
And I already am using the -c option for dchroot to specify the unstable chroot.

And you say write a script, so I put the following in ~/go
dchroot -d -c unstable ls
but I get the same error when I run "./go".

Thanks for your help!

Reply to: