[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: More Details about OOo install from backports (WAS:Re: switching OOo2 from upstream to backports)



On 06/05/2006 06:50 PM, Marc Shapiro wrote:
> Marc Shapiro wrote:
> 
>> Is the backport for OOo broken?
>> Is there a problem with openoffice.org-base?
>>
>> I just did:
>>
>>    apt-get -u -t sarge-backports install openoffice.org
>>
>> and got the following results:
>>
>> Reading Package Lists... Done
>> Building Dependency Tree... Done
>> Some packages could not be installed. This may mean that you have
>> requested an impossible situation or if you are using the unstable
>> distribution that some required packages have not yet been created
>> or been moved out of Incoming.
>>
>> Since you only requested a single operation it is extremely likely that
>> the package is simply not installable and a bug report against
>> that package should be filed.
>> The following information may help to resolve the situation:
>>
>> The following packages have unmet dependencies:
>>  openoffice.org: Depends: openoffice.org-base (> 2.0.1) but 2.0.0-4 is
>> to be installed
>> E: Broken packages
>>
>>
>>
> I ran:
> 
>    apt-get -u install openoffice.org-base
> 
> and got the following output:
> 
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> 
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  openoffice.org-base: Depends: java-gcj-compat but it is not installable or
>                                j2re1.4 but it is not installable or
>                                java2-runtime but it is not installable
> E: Broken packages
> 
> 
> So I obviously need one of the three packages mentioned above. 
> Unfortunately, none of these packages seem to exist, either in Sarge, or
> on backports.org, thereby making OOo uninstallable.
> 
> BTW: I have both j2re1.4.2_01 and jdk1.5.0_06 installed from the Sun
> packages
> 

Marc,

It works for me on sarge.  Be sure to apt-get update to resolve your
"openoffice.org-base (> 2.0.1) but 2.0.0-4 to be installed" problem.

I use the j2re1.4 Blackdown java from:
deb ftp://mirrors.ibiblio.org/pub/mirrors/blackdown/debian/ sarge non-free

The OOo2 help package from unstable will install without problems with
dpkg -i, or if you're careful, with apt pinning.

Regards,
Ralph



Reply to: