[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: USB not accepting new address

On Sun, 28 May 2006, Edson Marco Ferrari Junior wrote:

> Hi all!
> Im try connect a webcam Genius in Debian Sarge.
> I install the module spca52xxx and quickcam, but when connect the
> webcam in USB (2.0) in dmesg returns this message:
> usb 2-2: new full speed USB device using uhci_hcd and address 6
> usb 2-2: device not accepting address 6, error -71
[ ... ]

I had similar problems with my Creative WebCam NX Pro 2.  After much
googling I found the following suggestion worked.  Try plugging the camera
into a USB _1.x_ hub (or try bypassing the hub completely).  Either
workaround solved the problem for me.

My camera won't initialize correctly if it's plugged into any of my USB 2
hubs (or into an add-on NEC-chipset USB2 pci card for that matter).  It
seems this is a semi-common issue with webcams (not just the spca52xxx
driver).  I don't know why USB transactions with a webcam would be so
touchy, but a USB hard drive runs fine a full capacity through the same USB

-- Brad

Reply to: