[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: thinkpad suspend/resume woes

At 1147125694 past the epoch, rusi pathan wrote:
> I am using etch (2.6.15) on a thinkpad (x22) and use acpi
> instead of apm.  Now everything works fine except that
> 'sometimes' the system cannot resume.

Cool: I'm using 2.6.16-rc3 with an x40 and ACPI without

> What's odd is that the hard disk spins up but the LED
> (suspend) indicator still keeps blinking and then I have
> no option except to power cycle. The keyboard also remains
> unresponsive (i.e., Caps Lock doesnt turn on the light)
> and since no logs get updated I cannot debug the problem.

Does the machine respond to network traffic? (my guess is

> I have already tried kernel parameters like noapic etc.

I have to pass "acpi_sleep=s3_bios" to guarantee that
sleeping works properly. Have you tried that?

> and if I boot straight to shell using init=/bin/bash the I
> can make the machine suspend/resume any number of times
> using echo -n mem > /sys/power/state.

That could be because in single-user mode some kernel
modules are not being loaded and/or code paths executed.
That could suggest a bug in one of the modules you are

I have an acpid suspend.sh which is trigged by lid close
events and unloads the USB module prior to the suspend
action. Such a script can also turn off the backlight for
radeon-based thinkpads and do other stuff, like change VT to
avoid video corruption, etc. I think I based mine on

If you can identify a trouble-module by trial-and-error you
could use this to unload it before suspending. I'd then urge
you to report it to the kernel bugzilla if it isn't already

Jon Dowland

Reply to: