[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Stuck after upgrade (Unstable)

On Thu, May 04, 2006 at 20:30:25 +0200, Mohammad Halawah wrote:
> Hi everyone,
> Yesterday I made update|upgrade and got stuck with 
> libavahi-compat-libdnssd1
> The error message says:
> # apt-get install libavahi-compat-libdnssd1


> Unpacking libavahi-compat-libdnssd1 
> (from .../libavahi-compat-libdnssd1_0.6.9-8+b1_i386.deb) ...
> dpkg: error 
> processing /var/cache/apt/archives/libavahi-compat-libdnssd1_0.6.9-8+b1_i386.deb 
> (--unpack):
>  trying to overwrite `/usr/lib/libdns_sd.so.1', which is also in 
> package bonjour
> Errors were encountered while processing:
>  /var/cache/apt/archives/libavahi-compat-libdnssd1_0.6.9-8+b1_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)


> So I thought to mv the file /usr/lib/libdns_sd.so.1 temporarily to /
> to solve the 'overwrite problem' but the same error message appeared 
> again 
> trying to overwrite `/usr/lib/libdns_sd.so.1'

The package system still knows that the file should be there, therefore
it will refuse to install. It is normally better not to move around
system files unless you really know what you are doing.


> During this update|upgrade I lost most of KDE packages and when I tried 
> to install them back the process was stopped because of 
> the "libavahi-compat-libdnssd" problem.
> If anyone has an idea to fix it that's great, for other unstable users; 
> you are warned.

Where does this "bonjour" package come from? I can't find it in any of
the official Debian branches. It is probably the root of the problem. To
get rid of it you can proceed as follows:

1) Install libavahi-compat-libdnssd1 by brute force and let it overwrite
   the file:

   dpkg --force-all -i /var/cache/apt/archives/libavahi-compat-libdnssd1_0.6.9-8+b1_i386.deb

2) apt-get install -f

3) apt-get remove bonjour
4) apt-get --reinstall install libavahi-compat-libdnssd1

   (Just to be on the safe side; this is probably not necessary, but you
   never know...)

5) apt-get install kde

   (or something else, depending on what is missing)


Reply to: