[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel-image-2.6.8-3-686 fails to boot

Dear debian-user,

I am trying to upgrade the kernel from 2.4 to 2.6.
I installed the kernel-image-2.6-686 package (which depends on
kernel-image-2.6.8-3-686), but it failed to boot,
with messages as follows:

kernel  /boot/vmlinuz-2.6.8-3-686 root=/dev/hda5 ro
initrd  /boot/initrd.img-2.6.8-3-686
checking if image is initramfs...it isn't (ungzip failed); looks like an initrd
devfs: 2004-01-31 Richard Gooch
devfs: boot_options: 0x0
RAMDISK driver initialized: 16 RAM disks of 8192k size 1024 blocksize
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4528 blocks [1 disk] into ram disk...done.
VFS: Mounted root (cramfs filesystem) readonly.
vesafb: probe of vesafb0 failed with error -6
SCSI subsystem initialized
ide: Assuming 33MHz system bus speed for PIO modes: override with idebus=xx
ide0: I/O resource 0x1F0-0x1F7 not free.
ide0: ports already in use, skipping probe
ide1 at 0x170-0x177,0x376 on irq 15
pivot_root: No such file or directory
/sbin/init: 432: cannot open dev/console: No such file
Kernel panic: Attempted to kill init!

I tried "mkinitrd -o /boot/initrd.img-2.6.8-3-686 2.6.8-3-686"
but got the same messages.

I tried editing the boot option "root=/dev/hda5" to "root=/dev/sda5"
but got the same messages again.

I tried asking on debian-kernel but got no reply.

The relevant grub menu.lst paragraphs are:

title        Debian GNU/Linux, kernel 2.6.8-3-686
root         (hd0,4)
kernel       /boot/vmlinuz-2.6.8-3-686 root=/dev/hda5 ro
initrd       /boot/initrd.img-2.6.8-3-686

title        Debian GNU/Linux, kernel 2.4.27-3-686
root         (hd0,4)
kernel       /boot/vmlinuz-2.4.27-3-686 root=/dev/hda5 ro
initrd       /boot/initrd.img-2.4.27-3-686

rdev /boot/vmlinuz-2.6.8-3-686 : Root device /dev/cciss/c0d0p3
rdev /boot/vmlinuz-2.4.27-3-686 : Root device /dev/hda1

Any help would be much appreciated,

Reply to: