[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ctrl-Alt-Fx won't switch between virtual consoles after Sarge->Etch

On Sunday, 19.03.2006 at 22:37 +0100, Florian Kulzer wrote:

> >I recently upgraded this desktop from Sarge to Etch and pretty-much
> >everything has worked as well as before, or better, which is great.
> >
> >However, I find that I can no longer switch between virtual consoles
> >using Ctrl-Alt-F1, Ctrl-Alt-F2 etc.
> >
> >The 'getty's appear to be running OK, but I can't switch to them.
> >
> >$ ps ax|grep getty
> > 3911 tty1     Ss+    0:00 /sbin/getty 38400 tty1
> > 3912 tty2     Ss+    0:00 /sbin/getty 38400 tty2
> > 3913 tty3     Ss+    0:00 /sbin/getty 38400 tty3
> > 3914 tty4     Ss+    0:00 /sbin/getty 38400 tty4
> > 3915 tty5     Ss+    0:00 /sbin/getty 38400 tty5
> > 3916 tty6     Ss+    0:00 /sbin/getty 38400 tty6
> >14354 pts/3    S+     0:00 grep getty
> >
> >I don't even know where to start on this one: any ideas, people?
> Maybe this bug has propagated from Sid to Etch:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=345454

Interesting: this certainly describes my symptoms.  I can do a 'chvt N'
from a *root* session and successfully change VT and, once out of X,
successfully use Ctrl-Alt-F7 to get back into X.

> Sometimes it seems to be possible to fix it by running
> apt-get -f install
> apt-get install xlibs xlibs-data
> and restarting X.

Hmmm, there was nothing that wasn't up-to-date: I tried:

apt-get install --reinstall xlibs xlibs-data

too just for completeness, but this hasn't changed the behaviour.

> Furthermore, make sure that your /etc/X11/xorg.conf file has "xorg" as
> the value for "XkbRules" (and not "xfree86"). More details related to
> this can be found in /usr/share/doc/xserver-xorg/NEWS.Debian.gz

This suggests looking at xkb-data instead of xlibs, which I guess I
could investigate... don't really understand the implications of doing
that though.

> Also check your xorg.conf for occurrences of "DontVTSwitch", "VTSysReq",
> "XkbDisable" and "HandleSpecialKeys". These can interfere with the VT
> switching. ("man xorg.conf" has more info under "SERVERFLAGS SECTION")
> If the problem persists, check for warnings and errors in the Xorg log
> egrep '^\((WW|EE)\)' /var/log/Xorg.0.log
> and post them here together with your xorg.conf.

OK, doesn't look like anything untoward here:

# egrep '^\((WW|EE)\)' /var/log/Xorg.0.log

    (WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
    (WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
    (WW) NVIDIA(0): Not using mode "1152x768":
    (WW) NVIDIA(0):   horizontal sync start (1178) not a multiple of 8
    (WW) NVIDIA(0): Not using mode "576x384":
    (WW) NVIDIA(0):   horizontal sync start (589) not a multiple of 8
    (WW) NVIDIA(0): Not using mode "360x200":
    (WW) NVIDIA(0):   horizontal sync start (378) not a multiple of 8

# cat /etc/X11/xorg.conf

    # xorg.conf (Xorg X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following commands as root:
    #   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
    #   md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
    #   dpkg-reconfigure xserver-xorg

    Section "Files"
        FontPath	"unix/:7100"			# local font server
        # if the local font server has problems, we can fall back on these
        FontPath	"/usr/lib/X11/fonts/misc"
        FontPath	"/usr/lib/X11/fonts/cyrillic"
        FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath	"/usr/lib/X11/fonts/Type1"
        FontPath	"/usr/lib/X11/fonts/CID"
        FontPath	"/usr/lib/X11/fonts/100dpi"
        FontPath	"/usr/lib/X11/fonts/75dpi"

    Section "Module"
        Load	"bitmap"
        Load	"dbe"
        Load	"ddc"
        Load	"dri"
        Load	"extmod"
        Load	"freetype"
        Load	"glx"
        Load	"int10"
        Load	"record"
        Load	"type1"
        Load	"vbe"

    Section "InputDevice"
        Identifier	"Generic Keyboard"
        Driver		"keyboard"
        Option		"CoreKeyboard"
        Option		"XkbRules"	"xorg"
        Option		"XkbModel"	"pc105"
        Option		"XkbLayout"	"uk"

    Section "InputDevice"
        Identifier	"Configured Mouse"
        Driver		"mouse"
        Option		"CorePointer"
        Option		"Device"		"/dev/input/mice"
        Option		"Protocol"		"ImPS/2"
        Option		"Emulate3Buttons"	"false"
        Option		"ZAxisMapping"		"4 5"

    Section "Device"
        Identifier	"nVidia 6600"
        Driver		"nvidia"
    #Driver		"nv"

    Section "Monitor"
        Identifier	"Generic Monitor"
        Option		"DPMS"
        HorizSync	30-65
        VertRefresh	50-75

    Section "Screen"
        Identifier	"Default Screen"
        Device		"nVidia 6600"
        Monitor		"Generic Monitor"
        DefaultDepth	24
        SubSection "Display"
            Depth		1
            Modes		"1280x1024"
        SubSection "Display"
            Depth		4
            Modes		"1280x1024"
        SubSection "Display"
            Depth		8
            Modes		"1280x1024"
        SubSection "Display"
            Depth		15
            Modes		"1280x1024"
        SubSection "Display"
            Depth		16
            Modes		"1280x1024"
        SubSection "Display"
            Depth		24
            Modes		"1280x1024"

    Section "ServerLayout"
        Identifier	"Default Layout"
        Screen		"Default Screen"
        InputDevice	"Generic Keyboard"
        InputDevice	"Configured Mouse"

    Section "DRI"
        Mode	0666

Thanks for any further feedback

Please don't CC me on list messages!
Dave Ewart - davee@sungate.co.uk - jabber: davee@jabber.org
All email from me is now digitally signed, key from http://www.sungate.co.uk/
Fingerprint: AEC5 9360 0A35 7F66 66E9 82E4 9E10 6769 CD28 DA92

Attachment: signature.asc
Description: Digital signature

Reply to: