[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Watch out! In Etch, apt-get upgrade breaks KDE on every machine I upgraded...

Chris Howie wrote:
> Justin Piszcz wrote:
>>I fixed this by using the lib from a box with libXft2 2.1.7 instead of
> Thanks for the heads-up.  I found myself referring to your post after rebooting
> and nothing worked.
> It is possible to fix this without copying the .so from an older installation
> -- just downgrade the package.  This is how I solved the issue:

I did this using apt-get by including these in my /etc/apt/sources.list:
#got this while starting KDE:
# kdeinit: symbol lookup error: /usr/lib/libXft.so.2: undefined symbol:
# startkde: Could not start kdeinit. Check your installation.
#So downgraded libxft2 version --> 2.1.7-1, based on
deb http://snapshot.debian.net/archive pool xft
deb-src http://snapshot.debian.net/archive pool xft
deb http://snapshot.debian.net/archive pool xft2
deb-src http://snapshot.debian.net/archive pool xft2

and then doing:
$> sudo apt-get  install libxft2=2.1.7-1

Then I started dselect and marked this package as "hold".


> # dpkg --force-depends -r libxft2
> # wget \
> http://http.us.debian.org/debian/pool/main/x/xft/libxft2_2.1.7-1_i386.deb
> # dpkg -i libxft2_2.1.7-1_i386.deb
> # echo libxft2 hold | dpkg --set-selections
> Go back to KDM, CTRL+ALT+BKSP, and all is well.  Note that you'll want to
> unhold libxft2 (echo libxft2 install | dpkg --set-selections) after this is fixed.

Reply to: