[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Jerky PS/2 Mouse W/ 2.6 Kernel (Again)

I posted on this before and got an answer that didn't work (to be fair, the 
person responding did not think it would work).  I know this is not a rare 
problem and I'm having with Sarge and Sid (both new installs).  I've been 
told there are fixes, but I have not found one.  I've searched this list and 
seen it discussed, but NOT fixed.  (If I'm wrong, and used the wrong search 
terms or something, I'm open to links.)

I have a Logitech wireless mouse, 4 button, with a scroll wheel.  It works 
fine on Windows and Linux -- as long as I use the 2.4 kernel.  Once I start 
using the 2.6 kernel, it does not work.  I've tried both the 386 and K7 
kernels and it does not make a difference.  I tried installing gpm and 
changing the device in XFree86Config-4 to "/dev/gpmdata", but it doesn't 
help.  I know it receives the data from gpm, since if I stop gpm, the mouse 
no longer moves.  But with gpm, it is still jerky.  I've tried to find info 
on gpm.conf settings, but it wasn't easy.  Even in the docs, there are no 
suggested values for the sampling rate in gpm.conf.  I don't know if I should 
be trying values in the ones or thousands.

I also have a problem when I'm using the console, without X.  Whenever the 
mouse moves, I get messages like "2 bytes lost".  (I'm sorry I don't have the 
actual error messages, I had to reboot with a 2.4 kernel to get anything to 

I've heard about this before and I'm sure there must be a fix, but I'm having 
trouble finding it.  Any help or links is appreciated.  Once I've got it 
working, I'll write it up and post it so all the info will be in one place 
for anyone searching in the future.



Reply to: