[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2 mice under gpm with udev

Maybe this time I can ask a less stupid question...

Until now, on various thinkpads with 2.4 and 2.6 kernels (<2.6.10), I
have plugged in a USB mouse and it Just Worked.  That is to say both the
little red tit and the usb mouse were functional at once.  And what
worked for gpm was reproduced in X (via gpmdata).

Now I have a 2.6.14-2-686 kernel and udev.  And now the thinkpad 600E's
trackpoint still works (almost regardless of 'type=' setting in
/etc/gpm.conf) but the usb mouse skitters about, jumping a couple of
centimetres at every touch.  I see that you can define device2 and type2
in gpm.conf, but I cannot find how to separate the two devices, they
both seem to talk through /dev/input/mice (as before).  

How do i get the mice to be different devices, so that gpm can treat
them as different types?

(On a Dell Inspiron 8200, on the other hand, I get only the usb mouse,
and the touchpad is dead.  I'd quite like to know why this is too.)

For the thinkpad, the relevant part of dmesg follows, in case it helps.
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usb 1-1: new low speed USB device using uhci_hcd and address 2
mice: PS/2 mouse device common for all mice
ACPI: PCI Interrupt 0000:00:06.0[A] -> Link [LNKA] -> GSI 9 (level, low)
-> IRQ 
IBM TrackPoint firmware: 0x0b, buttons: 3/3
input: TPPS/2 IBM TrackPoint on isa0060/serio1
AC'97 read problem (ACSTS_VSTS), codec_index 0, reg = 0x2
[...many more of those...]
usbcore: registered new driver hiddev
AC'97 read problem (ACSTS_VSTS), codec_index 0, reg = 0x2
[...many more of those...]
ACPI: PCI interrupt for device 0000:00:06.0 disabled
input: USB HID v1.10 Mouse [Genius       NetScroll+Mini Traveler] on
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver



Reply to: