[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Screwed up USB

Hello gurus,

I've got a linux-2.6 i686 sarge machine running udev, dbus-1, and hal. A (l)user has just pulled a usb drive out before waiting for it to finish transfering data.

*Is* it possible to recover without rebooting the machine?

Here's what I've tried so far, which may have only made the situation worse:

I took down dbus-1 and hal w/ invoke-rc.d dbus-1 stop

I killed all processes that have an open file descriptor to the directory the flash drive was mounted on using lsof | grep <mount-point>

I tried to unmount the disk, but could not, so I wound up using pumount -l. Maybe that was a mistake...

Tried to kill -HUP udevd, pretty sure that was a mistake.

And now I'm out of options except to try randomly removing kernel modules or reboot. The user would rather I not reboot as the machine is running a model that's been number-crunching for days. The machine seems fine except that usb removable media doesn't seem to work and the load level is higher than normal.

Michael Peek

Reply to: