[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Hard drive issue



The drive may have re-mapped the bad sectors, a full surface scan & fsck
would probably be a good idea.


-----Original Message-----
From: Curtis Vaughan [mailto:curtis@npc-usa.com] 
Sent: Tuesday, December 06, 2005 10:12 AM
To: Debian-User List
Subject: Hard drive issue

Using a debian sarge system, with postfix and courier-imap.

Yesterday morning I started having IMAP connectivity problems with this 
mail server. Going to the box itself I discovered that the following 
error was occurring repeatedly:

kernel: end_request: I/O error, dev hdc, sector 61870207
kernel: EXT3-fs error (device hdc1): ext3_find_entry: reading directory 
#3866625 offset 0

So, I was certain this meant my HD was giving out on me.

After rebooting the system seemed fine for about 30 min. But then the 
same error starting occurring.

Again I had to reboot. Right after rebooting I shut all mail services 
down, and unmounted the drive in question (mounted as /home). Whereas I 
had another drive by the same manufacturer and the exact same type 
(size, etc.) I then decided to copy all of the failing drive to the new 
one. (i.e.: dd if=/dev/hdc of=/dev/hdd)

By all calculations (the drive was 80 G), this copy process should have 
taken no more than 50 min. Well over an hour and a half later I decided 
to stop the copying. I mounted the new drive just to look at it. It 
looked as though everything was there. But even a simple command as du 
on the file structure and size caused that process to hang. No matter 
what I tried I could not stop the process so I had to reboot.

I set /dev/hdc back to /home in fstab and rebooted. As I expected 
everything worked. But I was expecting meltdown at any minute. Well, 
that was yesterday. The system has been running since without a single 
error. So, what am I supposed to make of this?

Curtis


-- 
To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org



Reply to: