[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems installing multiple Adaptec RAID controllers with Debian 3.1

Hi List,

I've got this friend who's got this problem, I'll make it as short as I can.

I've installed Debian 3.1 onto a SCSI RAID5 provided by an Adaptec
AIC-7899. The system boots and runs fine. I'm able to access the array
via the I2O subsystem.

To increase my storage capacity for a cheaper price, I'm trying to add a
SATA RAID5 via an Adaptec 2410SA. After a few headaches with BIOS
configuration, the system will boot with the 2410SA installed alongside
the AIC-7899. So here's the problem:

With the stock 2.6 kernel that came with Sarge (2.6.8-1-386) I'm able to
see the SATA RAID array with the aacraid driver:

Nov  8 19:18:41 venus kernel: AAC0: kernel 4.2.4 build 7348
Nov  8 19:18:41 venus kernel: AAC0: monitor 4.2.4 build 7348
Nov  8 19:18:41 venus kernel: AAC0: bios 4.2.0 build 7348
Nov  8 19:18:41 venus kernel: AAC0: serial c7d8bffafaf001
Nov  8 19:18:41 venus kernel: scsi1 : aacraid
Nov  8 19:18:41 venus kernel:   Vendor: ADAPTEC   Model: AAR-2410SA RAID5  Rev: V1.0
Nov  8 19:18:41 venus kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
Nov  8 19:18:41 venus kernel: SCSI device sdb: 1757804544 512-byte hdwr sectors (899996 MB)
Nov  8 19:18:41 venus kernel: sdb: Write Protect is off
Nov  8 19:18:41 venus kernel: sdb: Mode Sense: 03 00 00 00
Nov  8 19:18:41 venus kernel: SCSI device sdb: drive cache: write through
Nov  8 19:18:41 venus kernel:  /dev/scsi/host1/bus0/target0/lun0: unknown partition table
Nov  8 19:18:41 venus kernel: Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 0

Looks good, but fdisk doesn't like it

lbarbuto@venus:~$ sudo fdisk /dev/sdb

Unable to open /dev/sdb

And no amount of fiddling seems to help. A post on my local Linux users
group suggested I try a newer kernel. So I did. I tried installing a
2.6.14 kernel with kernel-package, which went quite smoothly, until I
tried to boot. The system now hangs at this stage

Skipping already loaded module dpt_i20.
Setting up reslvconf...done.
Running 0dns-down to make sure resolv.conf is ok...done.
Setting up networking...done.
Starting hotplug subsystem:
		hw_random: already loaded
		generic: loaded successfully
		piix: already loaded
		aacraid: already loaded
I2O subsystem v1.288
i2o: max drivers = 8
i2o: Checking for PCI I2O controllers...
ACPI: PCI Interuupt 0000:04:01.1[A] -> GSI 17 (level, low) -> IRQ 16
iop0: controller found (0000:04:01.1)
PCI: Unable to reserve mem regioin #1:2000000@fc000000 for device 0000:04:01.1
iop0: device already claimed
iop0: DMA / IO allocation for I2O controller failed
ACPI: PCI interrupt for device 0000:04:01.1 disabled
	i2o_core: loaded successfully
	dpt_i2o: already loaded
	ignoring pci display device 04:03.0
	e100: already loaded
dpti0: Trying to Abort cmd=1822

(That may not be exactly correct, I had to manually copy it down off the
screen in a hurry) I can't review any more of the boot messages. Not
really understanding how ACPI works and what it can do/break, I tried
disabling it from the GRUB command line with pci=noacpi and then with
acpi=off. Both times the system hung at the same spot with (from memory)
the same error.

OK, can anybody suggest where I might go from here? Does anyone have
experience with this hardware combination (i.e. is it possible to put an
AIC-7899 and an 2410SA in the same Debian system and get them to work)?
Any pointers would be great.



Reply to: