[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X flickering

On Wed, 23 Nov 2005 liam.p.otoole@gmail.com wrote:

> jack wrote:
> > I'm running testing (etch) on x86. About a week ago, possibly
> > Wednesday 16/11 (sorry, I can't be more precise), after updating my
> > packages, I've started having problems with "flickering" in X. The
> > trouble is, I can't pinpoint the problem down. I'd be happy to file a bug
> > report, if only I could understand what's wrong.
> <SNIP interesting ASCII art>
> >
> >
> > What puzzles me the most is that I have the same problem in an xfce
> > session BUT NOT in a kde session. KDE is rock solid. Is seems to me
> > that xorg shouldn't be the culprit, but then? I thought maybe the wm
> > could be given the blame, but the fact that the problem stays
> > unchanged with metacity, sawfish AND xfwm4 make me uncertain.
> >
> Hi,
> I am not subscribed to the above list, so I'm writing to you directly.
> One thing that GNOME and XFCE (but not KDE) have in common is that they
> use settings daemons. I wonder if there is some strange interplay
> between these daemons and your xorg set-up?
> To test this, when in a GNOME session find the process called
> gnome-settings-daemon and kill it. (You will lose things like theme and
> font customisation, but nothing more). Does this solve your problem?
> Alternatively, start the same daemon in a KDE session. Does this
> *cause* the problem?
> Liam

(also forwarded to the debian-user list)

Aha. Well spotted. The plot thickens.

Killing gnome-settings-daemon under gnome is impossible (it restarts by
itself each time), so I can't check, BUT starting it under KDE produces
the same symptoms; the symptoms disappear after killing it. On the other
hand, after killing xfce-mcs-manager (under xfce) the problem persists.

However, the simple fact that the problem is now reproducible is a big
step forward. Thanks!

Ideas, anyone?

Riccardo `Jack' Lucchetti
Dipartimento di Economia
Università Politecnica delle Marche


Reply to: