[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Building ant from etch



On Fri, Nov 18, 2005 at 10:18:22PM +0000, Joseph Haig wrote:
> --- "Roberto C. Sanchez" <roberto@familiasanchez.net> wrote:
> 
> > On Fri, Nov 18, 2005 at 12:20:32PM +0000, Joseph Haig wrote:
> > > I am backporting ant-1.6.5 from testing to stable (as part of the
> > > process of attempting to backport openoffice.org) and it seems to
> > have
> > 
> > You shouldn't need to do that.  The only reason for depending on Ant
> > 1.6.5 is because of the dependency on gcj-4.0.  So, unless you are
> > backporting all of gcc-4.0, you don't need the newer Ant.
> > 
> 
> That is the case, gcj-4.0 is a build dependency for Openoffice.  Of
> course, it is entirely possible that I am missing something vital, as
> this is only my second attempt at backporting.  Is it possible (and
> sensible) to override the build dependency and use the version of gcc
> in stable?
> 

You can't use the gcj in stable, as it is not sufficiently advanced.
You can (1) backport all of gcc-4.0, or (2) use a non-free JDK from Sun
or Blackdown or IBM.

I am trying with the Sun JDK, but my build fails like this:

=============
Building project rhino
=============
/home/roberto/tmp/debian/openoffice.org/openoffice.org-2.0.0/ooo-build/build/ooo680-m3/rhino
mkout -- version: 1.5
-------------
dmake:  Error -- `./rhino1_5R4.patch' not found, and can't be made
'---* tg_merge.mk *---'

ERROR: Error 65280 occurred while making
/home/roberto/tmp/debian/openoffice.org/openoffice.org-2.0.0/ooo-build/build/ooo680-m3/rhino
make[1]: *** [stamp/build] Error 1
make[1]: Leaving directory
`/home/roberto/tmp/debian/openoffice.org/openoffice.org-2.0.0/ooo-build'
make: *** [debian/stampdir/build] Error 2


-Roberto
-- 
Roberto C. Sanchez
http://familiasanchez.net/~roberto

Attachment: pgpPyGyzefG5A.pgp
Description: PGP signature


Reply to: