[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Broken RAID array ...

Hash: SHA1

Hi all,

  It appears that for about a month my raid array is not working anymore
(this is an evaluation after having inspected the content of each
individual disk). I thinks it may be a bit longer. I was using raidtools
but, as I'm under unstable, this package was removed and may not have
been through that migration as well as I thought :(
After some investigation i found that it does not recognize it any more
because the two disks don't have the same UUID! as mdadm shows :

  % mdadm --examine --brief --scan --config=partitions
  ARRAY /dev/md0 level=raid1 num-devices=2 	\				
  ARRAY /dev/md0 level=raid1 num-devices=2 	\  				

As far as I can tell the disk actually used is /dev/sdb1 (sda1 content
is outdated).
I tried to force the array assembly but I got :

  % mdadm -A /dev/md0 --force
  md: md0 stopped.
  mdadm: /dev/sda1 has no super block - assembly aborted

So I tried to make sda1 faulty, remove it then reinstall it; but I got :

  % mdadm --fail /dev/md0 /dev/sda1
  mdadm: cannot get array info for /dev/md0

As far as I understand, it's because md0 is active... but I can't
activate it; It's a dead lock !!

To break this vicious circle, I thought I could reset sda1 UUID, but how
can I know the one to use, or may I just rebuild the array (without
loosing data of course !)
Or may i use any tool to set proper super block on sda1 ?
Is there a proper way to get myself out of that mess ?

Thanks for your advice.

PS : If some could explain how I get myself in that mess I would also
greatly appreciate it ... so i won't do it again !

- --
I prefer encrypted mail.
You can get my PGP public key(s) from :
  * The MIT's PGP Key Server : http://pgp.mit.edu/
  * My homepage : https://caniart.net/~nicolas/identity.html

Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


Reply to: