[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gmplayer not working


I tried to compile mplayer, and it worked. mplayer
runs flawlessly. Unfortunately gmplayer don't.

I compiled:

#CC=gcc DEB_BUILD_OPTIONS="--enable-gui --enable-menu"
debian/rules binary

(gcc is 4.0, i got some warninigs but no errors. If
compiled with 3.3 got any warning, but got exactly the
same problem)

If i type:

$mplayer myfile.mpg

It displays the video.

but if i type:

$gmplayer myfile.mpg

I got:

vo: X11 running at 1152x864 with depth 24 and 32 bpp
(":0.0" => local display)
libpng warning: Application was compiled with png.h
from libpng-1.0.18
libpng warning: Application  is  running with png.c
from libpng-1.2.8
libpng error: Incompatible libpng version in
application and library

i checked and /usr/include/png.h is a link to

and in png.h:

/* png.h - header file for PNG reference library
 * libpng version 1.2.8 - December 3, 2004

mplayer: MPlayer-1.0pre7

Any ideas?

Yahoo! Music Unlimited 
Access over 1 million songs. Try it free.

Reply to: