[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian sarge doesn't support > 30 GB harddrive ?? (+Workaround)

Maxim Vexler wrote:


I'm installing debian sarge (either linux26 or linux24) on my P4 1.6
pc, and failing to do so. Receiving 2 different (probably unrelated)
errors that will be detailed as follows.
The current situation is that I am unable to finish the base-system
installation phase for large disks, and those living without a "real"
debian :(

Temporary workaround offered towards end of e-mail.

-- PC configuration :
MB = Gigabyte 8sRX (revision F9, then flashed to F10c)
CPU = Intel Pentium IV 1600Mhz
RAM = DDR 256mb 233Mhz (memtest86 error check passed)
HD (failing) = Maxtor YAR41BW0 160GB ATA
                   Westen Digital  WD800JB 80GB ATA
     (working) = Segate ST310232A 10GB ATA
                      Quantum CT:224624A56IM30J 6.4GB ATA
NET = (DHCP) 8139too (Realtek Semiconductior Co. Ltd. RTL-8139/8139C/8139C+)

-- Problem reproduction :
=== For revision F9 of the motherboard bios the situation was as follows.
1. Sarge (kernel 2.4 & 2.6):
 1.a outputted the same error during the installation of base-system:

Console 1 <<<
[!!] Install the base syst
Debootstrap Error
Couldn't download apt.

Console 4 <<<
Oct 24 16:02:50 run-debootstrap[683]:
file://cdrom/pool/main/a/apt/apt_0.5.28.6_i386.deb was corrupt

Console 2 <<<
# To prove that debootstrap is lying.
~ # cp /cdrom/pool/main/a/apt/apt_0.5.28.6_i386.deb /
~ # md5sum /apt_0.5.28.6_i386.deb
ce8563844ee16e8367dc2991fbbfcf5 /apt_0.5.28.6_i386.deb
# Monitor -> Eye -> Keyboard copied so do allow minor typo error's.

=== For revision F10c of the motherboard bios the situation as follows.
1. Sarge (kernel 2.4) :
 1.a Screen flashes after the initial prompt of the kernel selection
(linux, expert, linux26, expert26) without any output.
Ctrl+Alt+F{1,2,3,4} work for a 1sec but then the screen resumes to
flashing. No option to even begin installation.
 1.b If loaded with [linux debian-installer/framebuffer=false] then
system load's kernel (initrd) and outputs "Segmentation fault". No
option to begin installation either.
2. Sarge (kernel 2.6) :
2.a Same behaviour as described in section above (revision F9)

-- Configuration options attempted in vain.
1. Replacing CDROM.
2. Replacing PSU (new 400w generic)
3. Burning installation media (3 times!).
4. Replacing Video Card's.
5. a. Replacing Hard Drive's (different vendor's).
   b. Connecting Hard Drive on hda / hdc / hdd, Single / Master /
Master with slave.

-- Configuration options not attempted
1. Selection a network repository instead of CDROM (Don't know how :))
2. Installing on SATA drive (None available)
3. Replacing CPU, Motherboard (Too expensive :))

-=-= Workaround =-=-
Be modest and use overall hard disk space no larger then 30 GB :) -
System installs as expected.

This is the first time I'm installing debian, in other word's this
installation is for testing and amusement purposes only. Yet, I would
appreciate a serious replay - It sure would be much more enjoyable if
it actually worked ;).
I am ready to try everything you suggest.

Thank you taking the time to read my mail.

Maxim Vexler (hq4ever).

Do u GNU ?

Are you positive these hdd's are bad? If these hdd's that you lebeled 'failing' are really bugged, get rid of them. Sarge is absolutely able to use 30GB without any special parameter. With only the 10GB and the 6.4GB in the machine, you won't even have the 30GB problem. By the way: whats the point on having a p4, if you deploy such a slow set of hdd's? Its not capacity, but speed. Get a new 7200rpm sata and be happy. Its worth paying for.
Also, check if you downloaded the lastest iso's.
And, if you decide to keep the 10GB and the 6.4GB in the machine, maybe its a good idea to create swaps in both, so you gain a little performance.

Reply to: