[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: APM suspend lost! (mypost: 4octrl3)

Ok, if I boot straight to console, suspend works ok. But it seems to fail when 
X is running.

I thought it could be the video driver, which was "radeon". I tried "ati", no 
improvements. Then I tried disabling dri, still no improvements.

So I rekon that it's not a kernel module that's causing the hang. Is this 
analysis sensible?

any help much appreciated..


On Tuesday 4 October 2005 10:48, rich lott wrote:

   I don't know what caused it, but my laptop won't come out of APM suspend.

   The laptop is a Dell Lattitude C640, running Etch, with the 2.6.12 kernel.
 The grub menu tells the kernel to not use ACPI (it doesn't work with bios),
 and apm --suspend works fine. But when I open the lid/press the button, it
 comes to life (noise, lights, back light of screen) but the screen is
 completely blank and everything just stays like that. There's no disk
 activity, so either it's died or it's waiting on something.

   This had been working fine for years, and suddenly it's stopped. Major
   inconvenience what with linux taking about 3 hours to boot up as well!

   Has anyone else noticed this, or could anyone give me pointers toward
   debugging the problem?

   many thanks,


Reply to: