[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem upgrading glibc, help appreciated

This might be quite a basic question.

I've Just done apt-get upgrade, and there seems to be a problem with
installing libc6. This is what I get:

Unpacking replacement libc6 ...dpkg: error processing
/mirror/debian/pool/main/g/glibc/libc6_2.3.5-6_i386.deb (--unpack):
unable to create `./lib/tls/ld-2.3.5.so': Permission denieddpkg-deb:
subprocess paste killed by signal (Broken pipe)Errors were encountered
while processing:
/mirror/debian/pool/main/g/glibc/libc6_2.3.5-6_i386.debE: Sub-process
/usr/bin/dpkg returned an error code (1)

I has a look at the permissions on /lib/tls which were d--------- root
root; I tried doing chmod 770 and got this error:

chmod: changing permissions of `tls': Operation not permitted

I am the root user, could someone explain why I can't change the
permissions on this directory (which will presumably fix the apt-get

Thanks in advance,

Reply to: