[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Package configuration blocked by double free error

Below I am re-posting part of a message from the archives because it exactly describes my problem. I have done a google search and have found this problem in debian and other distributions and have found bugs filed but have found no solutions. It was suggested on another list that I set MALLOC_CHECK TO 0 but this did not help. while my system remains functional at this point, I can not upgrade and many packages are either not upgraded or show as neither fully installed or uninstalled. I really don't want to have to re-install so if anybody knows the solution to this, PLEASE POST it.



Partial Quoted message from August archives:

Every time an install or upgrade attempts to configure I get this error:
*** glibc detected *** double free or corruption (!prev): 0x089a79c8 ***

The problems this is causing are rapidly spreading.  debconf in now not
installed properly, most installs don't configure for that reason alone.
I suspect the problem arises from the fact that I've pulled some
unstable packages, in particular glibc, into my mostly testing system.

Reply to: