[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Connect from Windows to LPR

After googling and still confused ...

I've got a lpr server with Epson dotmatrix.
I can print from localhost and from windows clients and other linux
boxes via lpr port. ( Windows clients have to be installed lpr support )
The problem is there's an old application that need to print to lpt port.
I've tried it using samba, and tried to map the shared printer to the lpt1.

C:\ net use lpt1: \\lprserver\sharedprinter /user:username password
System error 67 has occurred.
The network name cannot be found.

Looks like the net command can't find the resource.
But I can map users' home directory on the lpr server.
I also can browse the lpr server via windows' My Network Places.
However, when I double-clicked the shared printer, it does installing the
printer but after that the printer status is 'Access denied ubale to
which is common if we have not enough privileges.

What to do ?



This is part of my smb.conf :

          security = user
          printing = bsd
          printcap name = /etc/printcap
          load printers = yes         
    comment = All Printers
    path = /var/spool/lpd/lpr-gfi84
    create mask = 0700
    printable = Yes
    browseable = No
    public = Yes
    writable = No
    create mode = 0700
    comment = Printer Drivers
    path = /var/lib/samba/printers
    browseable = Yes
    read only = Yes
    guest ok = No
    comment = gfi office 84
    path = /var/spool/lpd/lpr-gfi84
    writeable = Yes
    public = Yes
    printable = Yes
    printer name = lpr-gfi84
    print command = lpr -r -h -P %p %s

Reply to: