[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: annoying eog warnings

On Thu, Sep 29, 2005 at 11:26:32AM +0900, Miles Bader wrote:
> When I run "eog" to view an image, it always outputs some warnings:
>    $ LANG=C eog ../images/image73-s1280x1024-a3-Ftriang-g1.8.png
>    ** (eog:5433): WARNING **: Failed to lock:  No locks available
>    ** (eog:5433): WARNING **: Failed to lock:  No locks available
>    ** (eog:5433): WARNING **: Failed to lock:  No locks available
> It's not just ugly either -- it seems to delay startup significantly (I
> gather it's timing out on something).
> eog --version says:   Gnome eog 2.10.2
> The above is from my work machine.  This _doesn't_ happen on my home
> system, and eog starts up much more quickly there despite my home
> machine being far slower.
> I wonder if it has something to do with my homedir being in NFS (though
> the image file above is on the local disk)?
> Anyone know what's going on and how I can fix it?

Your suspicion is probably correct.  It wouldn't be the first time that
file locking (i.e. fcntl(2)) and NFS don't play nice with each other...

Most likely, eog is trying to update Gnome's recently-used files stuff
(for which it needs to get a lock on the file before writing).
AFAIK, the file in question is ~/.recently-used -- not 100% sure though
(in case of doubt, use strace and grep for 'recent' in its output).

In such cases, it sometimes helps to move the file to some local file
system, and then create a symlink to it, i.e.

$ mkdir /tmp/yourusername
$ mv ~/.recently-used /tmp/yourusername/
$ ln -s /tmp/yourusername/.recently-used ~/.recently-used

(/tmp/ might not be the best choice, in case it gets purged on a
regular basis... but you get the idea :)

It's kinda ugly, but for me, this approach solved similar issues with
some Qt apps, so you might want to give it a try.  If it doesn't work,
you can always move the file back into your home.

Good luck,

Reply to: