[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Newb Hoses Install - Story at 11

>>An upgrade (under Etch) doesn't want to finish.  I clicked 'Mark All
>>Upgrades' in Synaptic, but it keeps failing on udev.
>>It says:
>>udev requires a kernel >= 2.6.12, upgrade aborted.
>>However, the newest kernel I show in Synaptic is only 2.6.8.
> Look for "linux-image-*" instead of "kernel-image-*", those packages
> have been renamed recently to make way for the use of kernels other
> than linux (freebsd and hurd come to mind).
Ah... I see it.  Ok, I've installed linux-image-2.6.12-1-386 by itself.
 I did try selecting this package w/all the 'Mark for Upgrade' stuff,
but I got same error as before.

However, now I get:
Preparing to replace udev 0.056-3 (using
.../archives/udev_0.068-2_i386.deb) ...udev requires a kernel >= 2.6.12,
upgrade aborted.
dpkg: error processing /var/cache/apt/archives/udev_0.068-2_i386.deb
(--unpack): subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:

Since it's still not finding the new kernel, do I just need to reboot?
And should I remove the older kernel package before doing so?  Will Grub
be automatically configured to point to the new image?

Eric P.

Reply to: