[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gnome-keyring-management alternative

I recently moved from KDE to Gnome and I'm very pleased with it, but I
having a few difficulties.  The two big ones involve encryption keys.  

I guess that at some point in the installation Gnome asked me for a
passphrase for a default keyring, but for the life of me I cannot
what I entered.  No problem, I'll just get rid of the old passphrase and
any data encrypted with it and use a new one.  Unfortunately I can find
anyway to do this.  The only program I've found that would allow me to
this (I think) is gnome-keyring-management.  Unfortunately it isn't in
Debian yet (I'm running unstable).  I tried using 'apt-get source' to
it from mentors.debian.org, and it worked fine, but when I try 'apt-get
build-deps' it runs into problems:

  root@volkswagon:/home/kt/system# apt-get build-dep
  Reading package lists... Done
  Building dependency tree... Done
  E: Build-dependencies for gnome-keyring-manager could not be
OK, that isn't very informative.  I've never used 'apt-get source'
so please bear with me.  I'm used to .tar.gz files, but I'm trying not
trash package management on this system.  

So I try to build it to see if I get anything more informative:

  root@volkswagon:/home/kt/system# apt-get source -b
  Reading package lists... Done
  Building dependency tree... Done
  Need to get 478kB of source archives.
  Get:1 http://mentors.debian.net unstable/main gnome-keyring-manager
2.11.0-1 (dsc) [817B]
  Get:2 http://mentors.debian.net unstable/main gnome-keyring-manager
2.11.0-1 (tar) [475kB]
  Get:3 http://mentors.debian.net unstable/main gnome-keyring-manager
2.11.0-1 (diff) [1774B]
  Fetched 3B in 0s (4B/s)
  Skipping unpack of already unpacked source in
  dpkg-buildpackage: source package is gnome-keyring-manager
  dpkg-buildpackage: source version is 2.11.0-1
  dpkg-buildpackage: source changed by Dan Korostelev
  dpkg-buildpackage: host architecture i386
  dpkg-checkbuilddeps: Unmet build dependencies: intltool libgnomeui-dev
(>= 2.6.0) libgnome-keyring-dev (>= 0.3.2)
  dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.
  dpkg-buildpackage: (Use -d flag to override.)
  Build command 'cd gnome-keyring-manager-2.11.0 && dpkg-buildpackage -b
-uc' failed.
  E: Child process failed

So I tried installing the dependencies by hand, but that doesn't seem to

Is there some other way I can change the password on the default

Also, does Epiphany use this keyring to store certificates or is the
device" a Mozilla thing?  I can't seem to find anywhere to reset the
on the security device either.  I went into Mozilla and cleared the
in there, but that had no effect on Epiphany.

Any help will be greatly appreciated.  


Kenneth P. Turvey <kt@squeakydolphin.com>
Home Phone: (314) 255-2199
Jabber IM: kpturvey@jabber.org

Reply to: