[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel panic - not syncing. No init found. Try passing init = option to kernel

Hi all

I am receiving the above error on my amd64 sid system. All was well until I tried to recompile my kernel to add some extra ide modules into the kernel. I forgot the append-to-version flag and created a new kernel-image with the same name as a previous one. I realised the mistake but wanted to check the new modules were compiled (didn't make-kpkg clean) and used 'dpkg -x' to extract the contents into the /usr/src directory. They hadn't so I deleted the files.

I then started having problems with Konsole, it opened but didn't give me a prompt so I rebooted only to be faced with the above error.

So far I have tried
1) Googling the error without success.
2) chrooting from i386 partition. Again doesn't seem to be possible this was due to i386 not having 64bit emulation. 3) Using dpkg-deb -X from the i386 partition to unpack a new stock kernel downloaded direct from debian.org. Then run mkinitrd to create the initrd. Failed! 4) Cross-compile custom kernel for amd64 on i386. Failed due to lack of amd64-gcc?? 5) Booting install cd to attempt rescue from there. Can't seem to access the existing data.

I do have a separate home directory and a back up of /etc so reinstalling is a possibility, but I would prefer not to.

Anybody that can help with any of the above, or suggest a good (preferably small) Live 64 bit rescue CD so I can chroot into this partition and fix it, your help would be much appreciated.



Reply to: