[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X.org Troubles: XMMS Errors Out, GnuCash Rendering Slow

	I tried upgrading my Debian unstable system to X.org, as described


	Everything seemed to work fine, and life went on.  However, some
time later, I noted that XMMS would no longer launch.  The error message is:

bash$ xmms
Message: device: default
Gdk-ERROR **: BadMatch (invalid parameter attributes)
  serial 171 error_code 8 request_code 2 minor_code 0

	(The serial value changes with each invocation attempt.)

	Clearly I upgraded something to an incompatible version, and broke
the app.  I've tried downgrading selected libraries and uninstalling all
visualizer plugins, to no avail.  So far, XMMS is the only thing I've found
that won't actually launch.

	I've also noted another issue with GnuCash:  It's repainting its UI
very slowly, as if it's using CPU-based rendering for everything.
Everything seems to work fine; it's just really slow.

	If I had to guess, I'd say that one of the library upgrades left
certain apps unable to find a compatible X visual mode, and they either
abort (XMMS) or fall back to unaccelerated rendering (GnuCash), depending on
the underlying libs.

	Any hints on getting at least XMMS running again would be greatly
appreciated.  Thanks in advance.


Reply to: