[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Asus A3E 5003, speakers problem



Hi group,
i have Asus A3E 5003, and using debian SID, but the internal speakers dont work. There have NO sound from then. Even noise.
There are some facts:
1. Linux kernel - 2.6.12 HERE
2. Boot THIS.
3. Modules in /etc/modules THAT.
4. Active modules after boot THERE.
5. Things in lspci HERE линк.

ALSA
./configure --help
                   Possible cards are:
                            seq-dummy, dummy, virmidi, mtpav, serial-u16550,
                            mpu401, serialmidi, loopback, portman2x4, pcsp,
                            ad1848-lib, cs4231-lib, ad1816a, ad1848, cs4231,
                            cs4232, cs4236, es968, es1688, es18xx,
                            gusclassic, gusextreme, gusmax, interwave,
                            interwave-stb, opti92x-ad1848, opti92x-cs4231,
                            opti93x, sb8, sb16, sbawe, wavefront, als100,
                            azt2320, cmi8330, dt019x, opl3sa2, sgalaxy,
                            sscape, pc98-cs4232, miro, msnd-pinnacle,
                            ali5451, atiixp, atiixp-modem, au8810, au8820,
                            au8830, azt3328, bt87x, cs46xx, cs4281, emu10k1,
                            emu10k1x, ca0106, korg1212, mixart, nm256, rme32,
                            rme96, rme9652, hdsp, trident, ymfpci, als4000,
                            cmipci, ens1370, ens1371, es1938, es1968,
                            maestro3, fm801, fm801-tea575x, ice1712, ice1724,
                            intel8x0, intel8x0m, sonicvibes, via82xx,
                            via82xx-modem, vx222, hda-intel, pdplus, hdspm,
                            asihpi, pcxhr, darla20, gina20, layla20, darla24,
                            gina24, layla24, mona, mia, echo3g, indigo,
                            indigoio, indigodj, powermac, sa11xx-uda1341,
                            armaaci, pxa2xx-ac97, s3c2410, au1x00, usb-audio,
                            usb-usx2y, vxpocket, vxp440, pdaudiocf,
                            sun-amd7930, sun-cs4231, sun-dbri, harmony
(azx  не видях ... има azt3328 ...)
intel8x0 не ми върши защото:
Module snd-intel8x0
  -------------------

    Module for AC'97 motherboards from Intel and compatibles.
                        * Intel i810/810E, i815, i820, i830, i84x, MX440
                        * SiS 7012 (SiS 735)
                        * NVidia NForce, NForce2
                        * AMD AMD768, AMD8111
                        * ALi m5455

    Module for Intel ICH (i8x0) chipset MC97 modems.

    ac97_clock    - AC'97 codec clock base (0 = auto-detect)



  Module snd-hda-intel
  --------------------

    Module for Intel HD Audio (ICH6, ICH6M, ICH7), ATI SB450,
               VIA VT8251/VT8237A
------------------------------
--------------------------

./configure --with-cards=hda-intel
make
make install
./snddevice

after

ls -l /lib/modules/2.6.12/kernel/sound/pci/hda/
total 112
-rw-r--r--  1 root root 90434 2005-07-20 18:07 snd-hda-codec.ko
-rw-r--r--  1 root root 21287 2005-07-20 18:07 snd-hda-intel.ko

alsaconf ...

same - no sound from speakers
dpkg -l | grep -i alsa
ii  alsa-base                       1.0.9b-2                   ALSA driver configuration files
ii  alsa-oss                        1.0.9-1                    ALSA wrapper forOSS applications
ii  alsa-source                     1.0.9b-2                   ALSA driver sources
ii  alsa-utils                      1.0.9a-3                   ALSA utilities
ii  alsamixergui                    0.9.0rc2-1-9               graphical soundcard mixer for ALSA soundcard
ii  gamix                           1.99.p14.debian1-2         Graphical sound mixer for ALSA
ii  libasound2                      1.0.9-3                    ALSA library
ii  linux-sound-base                1.0.9b-2                   base package forALSA and OSS sound systems
ii  snd-gtk-alsa                    7.8-1                      Sound file editor (GTK+ user interface)

alsamixer - and after that I switch on 6 channel sound. AFTER THAT I HAVE SOUND ON outside speaker jack.

I AM WITH ROOT, and i have group audio

discover -b -t -v
Loading XML data... ata pci pcmcia scsi usb Done
unknown unknown
unknown unknown
Intel Corp. Mobile Memory Controller Hub
Intel Corp. Mobile Graphics Controller
Intel Corp. Mobile Graphics Controller
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
Intel Corp. 82801 Mobile PCI Bridge
Intel Corp. 82801FBM (ICH6M) LPC Interface Bridge
Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller
Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
Ricoh Co Ltd RL5c476 II
Ricoh Co Ltd R5C552 IEEE 1394 Controller
unknown unknown
unknown unknown
Intel Corp. PRO/Wireless 2200BG
unknown unknown
unknown unknown
unknown unknown
unknown unknown
unknown unknown
unknown unknown

The result is: I HAVE SOUND but my internal speakers dont work ...

Many greetings

Reply to: