[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bttv/streamer: no audio recorded



Hi,

It was very long since you have posted your question, but if you haven't
 found solution please look at the bttv-HOWTO at
http://www.linux.com/howtos/BTTV/recording.shtml
It was very helpfull for me with one change:
I could not make btaudio working, but finally managed to record AVI with
 audio via line input of the primary sound card:

$ amixer -c 0 cget name='Capture Source'
numid=30,iface=MIXER,name='Capture Source'
  ; type=ENUMERATED,access=rw---,values=2,items=8
  ; Item #0 'Mic'
  ; Item #1 'CD'
  ; Item #2 'Video'
  ; Item #3 'Aux'
  ; Item #4 'Line'
  ; Item #5 'Mix'
  ; Item #6 'Mix Mono'
  ; Item #7 'Phone'

  : values=4,4

$ amixer cset name='Capture Source' 4
numid=30,iface=MIXER,name='Capture Source'
  ; type=ENUMERATED,access=rw---,values=2,items=8
  ; Item #0 'Mic'
  ; Item #1 'CD'
  ; Item #2 'Video'
  ; Item #3 'Aux'
  ; Item #4 'Line'
  ; Item #5 'Mix'
  ; Item #6 'Mix Mono'
  ; Item #7 'Phone'

  : values=4,4

$ amixer cset name='Capture Volume' 15
numid=32,iface=MIXER,name='Capture Volume'
  ; type=INTEGER,access=rw---,values=2,min=0,max=15,step=0

  : values=15,15

then:
$ streamer -t 00:10 -r 25 -a -F stereo -o movie.avi

Regards,
Marek

> Greetings- trying to track down a problem wherein I can watch, but not
> record, fine from a video4linux input. Video records fine, but no audio.
>
>  I can watch just fine using xawtv. But on occasion I would like to record
> to a file for later viewing, archiving, etc.  I *should* be able to use
> streamer for this, right? For example:
>
> streamer -o movie.avi -f mjpeg -F stereo -r 12 -t 0:10
>
>
> but even though the speakers come on and play the TV sound while the
> recording is happening, the resulting movie.avi contains no sound, only
> the video.
>
> Alternatively, if I use the following (directly from the streamer -h help
> screen):
>
> streamer -o quicktime.mov -f yuv2 -F stereo -r 12 -t 0:10
>
> I get the sound, but the video is all screwed up (neon colors, choppy,
> unwatchable).
>
> The no-audio outcome is also what happens if I record from xawtv or if I
> use the multi-step process to create an mpg from the streamer
> documentation:
>
> streamer -t 0:30 -s 352x240 -r 24 -o movie.avi -f mjpeg -F stereo
> lav2wav +p movie.avi | mp2enc -o audio.mp2
> lav2yuv +p movie.avi | mpeg2enc -o video.m1v
> mplex audio.mp2 video.m1v -o movie.mpg
>
>
> Any ideas what might be happennig? This is a debian box using a Pinnacle
> TV tuner, which uses the bttv driver. Kernel is 2.4.24.
>
>
> ----------------------------------------------------------------------
> Andrew J Perrin - http://www.unc.edu/~aperrin
> Assistant Professor of Sociology, U of North Carolina, Chapel Hill
> clists@perrin.socsci.unc.edu * andrew_perrin (at) unc.edu

-------------------------------------------------------



Reply to: