[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lost /dev/modem Symlink After Purging Udev And Reinstalling

Ritesh Raj Sarraf wrote:

Hash: SHA1

Leonard Chatagnier wrote:

This request for help is being reposted as no one offered any help.
Please, would someone respond with some help, even if its just a link
offering a solution that a relative newbie can implement.

After Purging udev including rming the entire /etc/udev directory and
reinstalling to fix a sound problem I have
to create the modem symbolic link, ln -s /dev/ttySHCF0 /dev/modem every
time I boot up.  I've tried
ChatagnierL-Home:/etc/udev/scripts# /etc/init.d/udev restart
Recreating device nodes...done.
After rebooting, still no /dev/modem and have to create symlink again
ChatagnierL-Home:/etc/udev/scripts#  /usr/bin/udevtest /dev/modem
version 056
looking at '/dev/modem'
sysfs_open_class_device_path failed
Googled for above message and found 7 items concerning older versions of
udev with pages of script that I wouldn't
dare try.

There were 2 or 3 files in /etc/udev/rules.d dir that were no recreated
after reinstalling udev that goes something like:
hfcpci.conf and 10 or 50sound.rules.  The hfcpci.conf is probably
pertinent to the problem.  How can I recreate it?

Considered running the script inputdev.sh, read sh man and info but
couldn't determine which option to use.  Never have run a script before
but it seems to use Debian I going to have to do it.  Could someone clue
me in if this is the
correct script to use and the proper switch to use.  I am a relative
newbie and not a programmer, just a user.
I've also read the udev manual and googled on the subject, and its over
my head.
A quick solution is desirable as my system is fully functional
otherwise(until the next upgrade/dist-upgrade anyway).  I'm using
kernel-image 2.6.8-2-686 an upgrading under testing with udev version
.056-2 installed.
There is no entry regarding /dev/modem, only a capi entry, in the
udev.rules file or in the devfs.rules file.

Thanks for any help,
Leonard Chatagnier

What modem are you using ?
Is it fully supported by the kernel or you use something else to emulate
it ?

- -- Ritesh Raj Sarraf
RESEARCHUT -- http://www.researchut.com
Gnupg Key ID: 04F130BC
"Stealing logic from one person is plagiarism, stealing from many is
"Necessity is the mother of invention."
Version: GnuPG v1.2.5 (GNU/Linux)


It's a Diamond Multimedia SupraMax 56i Voice PCI modem with Conexant HFC driver using .deb file hfcpci~1.deb.
Modem has always worked well until purgeing and reinstallation of udev.
Thanks so much for picking up my post.

Reply to: