[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem Setting DMA

On Sunday, 01.05.2005 at 09:05 -0400, Thomas H. George wrote:

> After finding the difference between my konfig file and my .config
> file I copied the former back over the .config, stepped through make
> config and was able to enable CONFIG_BLK_DEV_VIA82CXXX.  I compiled a
> new kernel and found hdparm -d 1 /dev/hdb turned on dma with no
> problem.


> Subsequently I ran make menuconfig and found it now included all the
> choices that were in konfig.
> So the problem is solved although I have no idea why some of the
> options had disappeared from .config.

Almost certainly because you forgot to run "make oldconfig" at some
stage.  This is required if you want to modify a configuration file that
was defined on a different kernel version, other the behaviour you
describe will happen.

Please don't CC me on list messages!
Dave Ewart - davee@sungate.co.uk - jabber: davee@jabber.org
All email from me is now digitally signed, key from http://www.sungate.co.uk/
Fingerprint: AEC5 9360 0A35 7F66 66E9 82E4 9E10 6769 CD28 DA92

Attachment: signature.asc
Description: Digital signature

Reply to: