[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need Help-YMF724F Sound Card And ALSA

On Saturday 23 April 2005 07:21, you wrote:
> Justin Guerin wrote:
> >On Friday 22 April 2005 04:36, Leonard Chatagnier wrote:
> >>Justin Guerin wrote:
> >>>On Tuesday 19 April 2005 03:35, Leonard Chatagnier wrote:
> >>>>Justin Guerin wrote:
> >>>>>On Sunday 17 April 2005 08:54, you wrote:
> >>>>>>Justin Guerin wrote:
> >>>>>>>Copying the list, so others might be able to help
> >>>>>>>
> >>>>>>>On Saturday 16 April 2005 18:49, you wrote:
> >>>>>>>>Justin Guerin wrote:
> >>>
> >>>[snip]
> Results of upgrading udev and running alsaconf after doing apt-get
> update->upgrade which upgraded
> udev to a newer version:
>     * after upgrading and rerunning alsaconf-nothing, same as before:
>     * lchata@ChatagnierL-Home:/usr/share/sounds$ play KDE_Drum_Break.ogg
>       playing KDE_Drum_Break.ogg
>       sox: Can't open output file '/dev/dsp': Too many levels of
>       symbolic links

Perhaps there is a udev rule or something that keeps setting up the /dev/dsp 
node as a link to /dev/dsp.  I would look under /etc/udev.

>       lchata@ChatagnierL-Home:/usr/share/sounds
>     * So logged out KDE and logged back in getting same play error
>       message as above but now am getting system sounds through sterio
>       speakers.  Some success at least.

OK, when your system sounds are running, check your arts configuration for 
which output source they're using.  My guess is, you're using alsa.

>     * Rerunning alsaconf-getting same results as above-system sounds
>       thru sterio polkaudio speakers but nothing else including
>       realplayer and play.

Do you know if realplayer and play are configured to use arts?  They probably 
aren't by default, which means you'll have to either wrap them with the 
artsdsp wrapper, or wait for arts to release the lock on the sound device 
node, then attempt to play a sound using alsa.  That means checking the setup 
of play and realplayer and making sure you tell them to use alsa, not oss.  I 
don't know that play can be configured to use alsa, but I suspect that 
realplayer can.

>     * Rebooting and testing again-Again nothing works and also lost
>       system sounds or perhaps more accurately KDE builtin sounds.
>       Rerun alsaconf again-regained sys/KDE builtin sounds but nothing
>       else-play still gives too many levels of symbolic links and
>       realplayer plays video great but no sound.

When you lose sound, and have to run alsaconf again, you can avoid that by 
running "alsactl store" once your sound is working (at least for system 
sounds).  That way, they should survive a reboot.

>     * Logged out KDE and reinstalled udev from tty1-Ran alsaconf and
>       play from tty1 but no sound.  Logged into KDE still have sys
>       sounds but play still gives too many levels of symbolic links and
>       no sound on realplayer.
>     *  MV /etc/alsa to /etc/oldalsa and ran alsaconf which gave this
>       error message:
>     * Running update-modules...
>       Loading driver...
>       run-parts: failed to open directory
>       /etc/alsa/modprobe-post-install.d: No such file or directory
>       FATAL: Error running install command for snd_ymfpci

Oops, my bad.  /etc/asla/ is created by alsa-base, and it probably would have 
been better to purge and reinstall than to move it out of the way.  However, 
since the problem is with the oss device node, and not alsa's, this isn't 
really necessary.

>       Setting default volumes...
> ===========================================================================
>==== Now ALSA is ready to use.
>        For adjustment of volumes, use your favorite mixer.
>        Have a lot of fun!
>       ChatagnierL-Home:/etc#
>       Play still gives same error message and no voice on realplayer.
>       Logged out and into KDE with same results.
>       ChatagnierL-Home:/usr/share/sounds# play KDE_Desktop3.wav
>       playing KDE_Desktop3.wav
>       sox: Can't open output file '/dev/dsp': Too many levels of
>       symbolic links ChatagnierL-Home:/usr/share/sounds#
>     * Rebooting and running alsaconf from tty1-same results.  Ran artsd
>       -a alsa hoping it would get KDE sound apis working.  TTY1
>       locked-CNTR C to get prompt back. Ran artsd -D /dev/dsp and artsd
>       -a alsa in KDE terminal with this
>       output:
>       lchata@ChatagnierL-Home:/dev$ artsd -a alsa
>       can't register Arts::MidiManager
>       There are already artsd objects registered, looking if they are
>       active...
>       Error: Can't add object reference (probably artsd is already
> running). If you are sure it is not already running, remove the relevant
> files:
>              /tmp/mcop-lchata/Arts_SoundServerV2
>              /tmp/mcop-lchata/Arts_SoundServer
>              /tmp/mcop-lchata/Arts_SimpleSoundServer
>              /tmp/mcop-lchata/Arts_PlayObjectFactory
>              /tmp/mcop-lchata/Arts_AudioManager (Note: have run artsd
>       before)
Arts probably already is running, so don't worry about the above error 

>       lchata@ChatagnierL-Home:/dev$ artsd -D /dev/dsp
>       ALSA lib pcm.c:2068:(snd_pcm_open_noupdate) Unknown PCM /dev/dsp
>       Error while initializing the sound driver:
>       device: /dev/dsp can't be opened for playback (No such file or
>       directory)   (?????????)

Instead of using the -D option, use the -a option and specify OSS, if you 
really want arts to try using oss.  However, since it's working with alsa, I 
wouldn't bother.

>       lchata@ChatagnierL-Home:/dev$
>     * Ran the artsd commands as root and
>       got:

You don't want to do this.  It's not necessary since you're in the audio 
group, and this link problem is not a permissions issue.

>       ChatagnierL-Home:/dev# artsd -a alsa
>       unix_connect: can't connect to server
>       (unix:/tmp/mcop-root/ChatagnierL-Home-195d-426a3109)
>       ChatagnierL-Home:/dev# artsd -D /dev/dsp
>       ALSA lib pcm.c:2068:(snd_pcm_open_noupdate) Unknown PCM /dev/dsp
>       Error while initializing the sound driver:
>       device: /dev/dsp can't be opened for playback (No such file or
>       directory)
>       ChatagnierL-Home:/dev#
>     * Reran alsaconf from KDE terminal as
>       root:
>       ChatagnierL-Home: /dev#
>       alsaconf
>       modinfo: could not open snd: no such device(this came up 3 times
>       brfore the  alsaconf GUI appeared)                The same no such
>       file or directory and fatal error running install command for
>       snd_ymfpci occurred as above.  Play and realplayer test results
>       were same as before.
>     * Justin, I think I tried out all the suggestions and then some
>       since my original post.  Hope there is something here that leads
>       to a solution and not info overload.  Ready to try anything else.
>       KDE built in sounds are great but that's all I can hear.
> Thanks again,
> Len C

I think you're getting somewhere.  First off, I think you can focus your 
efforts on udev, since it's creating the /dev/dsp link.  Check through its 
configuration, or purge and reinstall if there's nothing you wouldn't mind 

Second thing to remember, alsa and arts are running fine.  You can set the 
preferred output to some applications, like XMMS, to use arts, and things 
should be fine.  On the other hand, some applications don't let you choose 
arts as an output, or even alsa.  If those are the ones you're concerned 
about, then you'll have to chase this down until you get oss (or rather, oss 
emulation) worked out.

Let me know if you choose the latter path, and if purging and reinstalling 
udev does you any good.


Reply to: