[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fakeroot make-jpkg permissions


Thanks everyone for the response.

I ran the command from my home directory (i.e not in the folder where the file was) as Adam suggested and it worked!


Paul Hopton

Hi Everyone,

I'm a little new here, so excuse me if I'm missing the obvious.

I want to set up Tomcat 5.5 so I need to install the j2sdk 5.0. I've
got the binary from sun, java-package and fakeroot installed. .

paul@debian:/usr/local/bin$ fakeroot make-jpkg jdk-1_5_0_02-linux-i586.bin

goes through the make process but then bombs out here:

cp: cannot create regular file
`/usr/local/bin/sun-j2sdk1.5_1.5.0+update02_i386.deb': Permission denied

Aborted (/usr/local/bin/).

What am I missing? Any clues would be a great help.

Looks like you're running the command in /usr/local/bin as a normal
user, so when it tries to save out the deb, it can't due to
permissions. Run the same command in your home directory and all
should work.



Reply to: