[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: fakeroot make-jpkg permissions

Hi Thanks for answering
What are the filepermissions of that file?

For the bin file, they were initially set to read write for user and read for all others. I tried setting them to rwx for all and then rw, but same result. But it seems that the problem is in creating the new file. But if fakeroot is really "faking root", it shouldn't be an issue, or am I being too literal?



Hi Everyone,

I'm a little new here, so excuse me if I'm missing the obvious.

I want to set up Tomcat 5.5 so I need to install the j2sdk 5.0. I've got the binary from sun, java-package and fakeroot installed. .

paul@debian:/usr/local/bin$ fakeroot make-jpkg jdk-1_5_0_02-linux-i586.bin

goes through the make process but then bombs out here:

cp: cannot create regular file `/usr/local/bin/sun-j2sdk1.5_1.5.0+update02_i386.deb': Permission denied

Aborted (/usr/local/bin/).

What am I missing? Any clues would be a great help.


Paul Hopton

Reply to: