[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Raid, fsck, superblock could not be found

--- Alvin Oga <aoga@mail.Linux-Consulting.com> wrote:
> > # cat /boot/grub/device.map 
> > (hd0)   /dev/sda
> > (hd1)   /dev/sdb
> > (hd2)   /dev/sdc
> i'm not sure about that .. but lets assume its right

Not sure about that myself. Tried also putting only "(hd0) /dev/md1" but it did
not appear to make any difference.

> > ## default grub root device
> > ## e.g. groot=(hd0,0)
> > # groot=(hd0,0)
> whacky ...  root should be "/dev/md0"  not the default of an individual
> sata disk 

You mean /dev/md1? /dev/md1 is mounted as /boot according to my /etc/fstab.

Tried also "# groot=/dev/md1" but did not see any difference. 

> > title           Debian GNU/Linux, kernel 2.6.8-2-686-sata-raid 
> > root            (hd0,0)
> > kernel          /vmlinuz-2.6.8-2-686 root=/dev/md2 ro 
> > initrd          /initrd.img-2.6.8-2-686-sata-raid
> does initrd.img support raid ??
> 	- if it does, does it have enough tools/config to assemble
> 	the raid array 
> 		- eg mdadm, config files, raidtools, ..

/initrd.img-2.6.8-2-686-sata-raid contains "most" modules + sata_nv + raid0 +
raid1 + raid5, nothing more.

> 	- i'm guess not, since it doesnt boot by itself, but does
> 	work when you manually mdadam'it

But it does seem to be able assemble and fsck the "/" partition which is a
raid5 array *BEFORE*(!) it tries to fsck /dev/md1. Why can't it handle /dev/md1
the same way as it just did for /dev/md2??

Here are some more messages from the screen as the system boots, order of
messages is preserved:

md: raid0 personality registered as nr2
md: raid1 personality registered as nr3
raid5: using pIII_sse
raid5: raid level 5 set md3 active with 3 out of 3 devices, algorithm 2
mdadm: /devfs/md/3 has been started with 3 devices
Adding 1959672K swap on /dev/md3 Priority: -1 Extensions: 1
Checking root file system...
fsck 1.35 (28-Feb-2004)
/dev/md2: clean, 190848/60801024 files, 16336880/121587904 blocks
Ext3 FS on md2, internal journal
All modules loaded
Capability LSM initialized

Checking all file systems...
fsck 1.35 (28-Feb-2004)
fsck.ext: Invalid argument while trying to open /dev/md1
The superblock could not be read or does not describe correct ext2 filesystem.
If the device is valid and it really contains an ext2 filesystem (and not swap
or ufs or something else), then the superblock is corrupt, and you might try
running e2fs with an alternative superblock
  e2fsck -b 8193 < >

fsck failed. Please repair manually.

So, as you can see, first it fsck'ed "/" (on raid5, /dev/md2) and found it to
be clean. Why can't it do the same for /dev/md1 LATER? I'm puzzled.



Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site!

Reply to: