[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Repairing a corrupted system When dselect Hick ups

	I did run the suggested commands to rebuild the libraries
based upon installed modules and had a somewhat surprising result.

	On my home system, the /lib directory may now be back to what
it was, but I have one other obvious discontinuity on that same system.

	Last Fall, while I was running dselect, the process of
updating all the packages got interrupted.  Now, if I run dselect and
go to the selection screen (2) and simply hit enter to go back out
without doing anything, I get the conflict management screen.  If I
simply start hitting enter which is usually the best course, I do get
out and it tells me there are 0 packages to install, remove or upgrade
which is what one would expect after having done absolutely
nothing.:-).  I go along and answer yes to the question whether I want
to erase previously downloaded .deb files and it then gives me the
screen to select what to do next and I hit 6 to get out.

	Next time I go back in, no matter what I do, I will still get
that extra conflict resolution screen that doesn't end up selecting

	When I ran the reinstallation commands of

  dpkg --get-selections | sed -ne 's,install$,,p' | \
    xargs apt-get install --reinstall --yes

I got the following error:

Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package de

	I tried the same thing on the system I have at work that
doesn't complain about anything and got the very same error plus one
that is self explanatory

Sorry, re-installation of ae is not possible, it cannot be downloaded.
E: Couldn't find package de

	The only other odd thing my home system started doing after
that update that went wrong is that soon after booting, any ps command
plus several other commands besides ps will trigger an error which I
will illustrate by looking for a process called vx which is a
voice-activated sound recorder I wrote that runs as a daemon.

1wb5agz$ps ax |grep vx |grep -v grep
Unknown HZ value! (90) Assume 100.
  653 ?        S      0:43 vx

	The command executes and so do any others that produce the
unknown hz value, but it didn't do that before the update and its
almost twin brother at my work place successfully updated and does not
do that so I know something is wrong.

	Any ideas as to what I should look at next?

	Thanks again.

Martin McCormick WB5AGZ  Stillwater, OK 
OSU Information Technology Division Network Operations Group

Reply to: