[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Newbie: Postfix & cyrus-imapd question HELP PLEASE

Quoting James Marcinek <jmarc1@jemconsult.biz>:

> Hello everyone,
Hi.  There is no need to put "HELP PLEASE" in your subject.  The assumption
around here is typically that those people asking questions do so because
they need help.

> I'm in the process of getting an OpenGroupware install on a Debian system.
> I'm
> using Postfix and cyrus-imapd as I've had success in the past on Red
> Hat/Fedora.
> This is my first experience with a Debian release and with the exception of
> getting cyrus configured (and accessible), everything is up and running. The
> is configured and tested. The default Debian was to run in a chrooted
> environment. I modified the postfix configuration files (master.cf) to
> change
> this to a non-chrooted environment as I'm using lmtp.
It would be very helpful if you were to specify which release of Debian
and/or what versions of cyrus, postfix, and opengroupware you are using.

> Now I'm neither a Debian Postfix or cyrus expert to start, but I do have
> this
> running on my RHEL 3 system and I haven't really had any issues. I have the
> autoquotacreate set to -1 which will allow the addition of mailboxes
> automatically, so I've never had to manually add mailboxes.
You have autoquotacreate set to -1 on RHEL, Debian or both?  Also, on which
systems does it function as expected?

> One of the problems I've had is I can't access cyradm with the cyrus user
> account? Per some of the system doc's I added the cyrus user with the:
> saslpasswd2 -c cyrus
Was the cyrus user not added to the system for you by the install scripts?

> command and verified this with the: sasldblistusers2. When I try to use
> cyradmin
> this still doesn't allow connection. I know that those commands are part of
> cyrus-sasl but at this point I'm reaching because I've compared settings to
> my
> working configuration of Postfix and cyrus... I've tried starting the
> saslauthd
> directory but no processes are running after I issue the command, and the
> exit
> code I get is 0 with no errors. 
Check your saslauth configuration and /etc/inetd/conf.  If it is set to
run as a deamon, you will alwyas see the process running.  If it is set to
run from inetd, then you will see a process when a connection is active.
Also check your /etc/hosts.allow to make sure that the connections are

> Can someone help me out here? In addition to the above:
> - How do I get into the cyradmin with the cyrus account? I've set a password
> up
> for the user ID but I can't login?
Try this (as root):

# su - cyrus -c "cyradm -user cyrus localhost"

It should prompt you for the password.

> - Do I still have to add the imap and pop3 lines to /etc/inet.d or is this
> controlled by cyrmaster? I seen docs indicating to put the lines in and
> ones
> stating to remove (from inetd.conf)
On my system, they are in inetd.conf

> - Do I have to use saslauthd?
Depends on what for.  There are a number of different ways to authenticate

> - Is there a way I can verify if postfix is not running chrooted?
Check /etc/postfix/master.cf.  If the line for smtp has a y in the chroot
column, then yes it is, otherwise not.

> I've been all of the place reviewing docs and what not. Any help would
> relieve
> my growing headache!
If you tell us which docs you have tried, we might be able to give you
better alternatives.

> thanks,
> James

-Roberto Sanchez

This message was sent using IMP, the Internet Messaging Program.

Reply to: