[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Boot problem with a moved ext3 partition

Thanks for the help and sorry for the late.
I've followed your instractions:

> First change the partition type to Linux. Does e2fsck run properly now?

Done, it works properly

> Then edit /boot/grub/menu.lst to your new settings, something like:
> title           Debian GNU/Linux, kernel 2.6.10
> root            (hd0,4)                         <--- this is your extended partition
> kernel          /boot/vmlinuz-2.6.10 root=/dev/hda5 ro <--- idem.
> savedefault
> Also check your XP record (I don't run windoze, so I can't help you with
> that one).


> Then run grub and type:
> root (hd0,4)
> setup (hd0)

I don't know how to execute this last step.
Booting with the debian cd I execute all the steps of the debian
installer main menu. At the step to partiton the disk I use the
existent ext3 partition keeping the content and then if I open the
shell I found  my ext3 partition mount on /target but the command grub
isn't available. I tried to execute the grub on my partition executing
the command 'chroot /target /bin/sh', but grub fails saying that there
is a problem with the btem. I tried also to execute the step of the
debian installer main menu to install grub but it fails.

Any help.


Reply to: