[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How do I unpin a package in synaptic?

I used synaptic to lock to a certain version of libglade2.  This worked.
I now wish to unlock that, and let libglade2 run free to whatever version it 
I can click on libglade2 then packages and uncheck lock version.  At this 
point libglade2 vanishes from the pinned status screen.  However, while it 
shows the installed version synaptic does not display any latest version.  If 
I click in package details versions I see there is the newer version 
available.  Further, apt-get install libglad2 quickly downloads and installs 
the new version.  I restart synaptic and the newversion is shown as pinned.
I uncheck the lock version, close synaptic and restart synaptic and it is 
pinned again.
At one point I had this package pinned in apt/preferences, but I have removed 
dpkg --get-selections reports that it is installed but it is not on hold 
So this package is not mentioned in preferences, nor held in dpkg 

How and why is synaptic pinning it?

The libglade2 is now the proper one for sarge, I had previously held it back 
because it broke synaptics icons.  I have tried this procedure in the sarge 
version of synaptic and the unstable version of synaptic.

I have reviewed the bug reports for synaptic and this is not mentioned.  It is 
what I would imagine a very common procedure so I must presume that if it 
were a bug, it would have been recognized by now.  I can only conclude that I 
don't understand what I am doing properly.

Am I supposed to close synaptic some way special so that the unlocking of a 
package gets saved?
Is there a file I can edit?
I purged synaptic and reinstalled it, the unstable version as it supposedly 
has a nice feature re: dependencies and recommends.  libglade2 is still 
pinned.  I purged it, how can it still be pinned.  It's the current version 
available from the mirrors, it's not local or anything,  why is it pinned?  
Why can't I unpin it?
It seems as if synaptic and apt-get are using a different set of rules for 
determining things.  
What am I missing?

Reply to: