[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Fwd: SMT & P4HT on I865]

 Hi list,

I've encoutered some problems this afternoon ( France guys, it's 7pm right now ;) ). I tried to install a debian on this hardware :

Intel i865 + dual DDR 400
Pentium 4 HT
ICH5 controller but I use one P-ATA ( IDE ) Drive.

I tried debian testing, with 2.6.3 kernel default, it works fine, but Hyperthreading is not assumed, even if I enabled it in BIos. So I recompiled the kernel, the debian 2.6.8. First, this fuck... sh.. refuse to boot, unable to mount root fs. This is not my first kernel recompilation, I have already compiled more than 100 kernels on several computeur and servers and wrote article about it, it's my job ( System engineer ). There is no log, due to the quick kernel panic, and my ide controller is "built-in", such as my FS. My /boot/grub/menu.lst is good too. So I tried a 2.6.7 from kernel.org,and of course it works great with the same .config and even a 2.6.10 still from kernel.org and it works really good too. Well, the 2.6.8 sucks...but I don't care, my 2.6.10 is allright.

Another thing interesteding, if I activate HT in the bios, and SMP is set, the kernel won't boot, whatever the kernel version ( 2.6.8 2.6.7 and 2.6.10 ). It bugs, and shows messages about APIC and Null pointer exception, it look likes the 2 virtuals processors don't run well together. I don't understand why, is there something special to activate ? In fact, it's just the SMP option who matters, SMT or not SMT.

So I thought that my P4 HT is not hypertreadable, and I tried Gentoo live cd ( ;) ) and Knoppix live cd. It works great, detects 2 processeurs, 12 000Bogomips and runs very well.

So the P4 is hyperthreadable ( Knoppix and gentoo work fine ), my kernel configuration is good ( same .config ) but the debian won't boot whatever the kernel if SMP is set in the bios.

Any feedback would be apreciated or experience with this hardware.

Best regards,


Reply to: