[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.6.8 won't boot

Roberto Sanchez wrote:

Muhammad Reza wrote:

Dear Lists,

I'm stuck with compiling debian kernel-2.6.8 source at Sarge, this is
what exactly i did...

debian:/usr/src# ln -s kernel-source-2.6.8 linux
debian:/boot# cd /usr/src/linux
debian:/usr/src/linux# cp /root/config .config
debian:/usr/src/linux#patch -p1 </root/bootsplash-3.1.6-2.6.8.diff
debian:/usr/src/linux#make menuconfig
debian:/usr/src#make-kpkg --initrd --revision=custom.1.0 kernel_image
debian:/usr/src/linux# cd ../
debian:/usr/src# ls
kernel-image-2.6.8_custom.1.0_i386.deb  kernel-patches
kernel-source-2.6.8  kernel-source-2.6.8.tar.bz2  linux
debian:/usr/src# dpkg -i kernel-image-2.6.8_custom.1.0_i386.deb

but new compile kernel wont boot with this error...

RAMDISK: cramfs file system found at block 0
RAMDISK: loading 3620 block [1 disk] into ramdisk done..
Kernel Panic:VFS:unable to mount root fs on unknown_block(3.1)

please help me...to solved this problem..
here is .config and menu.lst in attach....

Have you tried without an initrd?  Also, do you have /boot
on a seperate partition?

-Roberto Sanchez

I'm already tried without --initrd, the last result it same, kernel won`t boot cause unable to mount root file system. And fyi, with or without --initrd, ext2, ext3 and reiserfs is compiling static to my 2.6.8 kernel.
this my mtab from previous good booting kernel...
debian:~# uname -a
Linux debian 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i686 GNU/Linux
debian:~# cat /etc/mtab
/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
/dev/hda9 /home ext3 rw 0 0
/dev/hda8 /tmp ext3 rw 0 0
/dev/hda5 /usr ext3 rw 0 0
/dev/hda6 /var ext3 rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0


Reply to: