[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel Panic VFS: Unable to mount root fs on unknown-block(3,1)

Ladies and Gentleman,

In order to use my shorewall/2.6 based firewall to route IPSECed
(openswan) wireless, I need to apply these patches from the
netfilter patch-o-matic-ng (extra) to the 2.6.6 kernel:
1) ipsec-01-output-hooks
2) ipsec-02-input-hooks
3) ipsec-03-policy-lookup
4) ipsec-04-policy-checks
5) policy

I have done so and am trying to compile the kernel for my VIA based hard
ware. When trying to boot the new kernel, I run into the common
(according to google) error message:

>Kernel Panic VFS: Unable to mount root fs on unknown-block(3,1)

which seems to imply that the kernel can't access my reiserfs root

I have looked around on the web extensively and tried/fixed a lot of
things, including changing my grub boot options to "kopt=root=0301 ro"
and kompiling reiserfs support non-modular into the kernel, but I can't
get it to work.

The one thing I found and haven't tried is using initrd (as proposed
e.g. by http://www.hjackson.org/blog/archives/000105.html), because I'm
fond of encrypting my swap space and have to reboot with non-encrypted
swap space every time I want to install an initrd-based kernel image
(through dpkg on my debian system).

I was wondering whether a kernel wiz can have a quick look into my
.config (attached) and give me some more hints. I have also attached my
/boot/grub/menu.lst and my /etc/fstab to give a clear picture of my

Thanks for any hints, Joh

Attachment: 2.6.6-.config
Description: Binary data

Attachment: menu.lst
Description: Binary data

Attachment: fstab
Description: Binary data

Reply to: