[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Hi there,

thanks to some off-list comments I was able to get the
CardBus adapter working.

It seems to be a (known?) bug in uhci-hdc.c and there
are some patches for different versions suggested on
the kernel mailing list, but none of them worked for
me. Anyway, when I booted with the noirqdebug option,
my system froze. I tried 2.6.7 and 2.4.2 kernels and
it made no change. When I turned off acpi, I was able
to get a "Sharing IRQ 11", but nonetheless after that
I got the "IRQ 11: nobody cared" message again.

Then, I downgraded to a 2.6.7 kernel image, booted
with inserted CardBus USB adapter and hotplug as well
as pcmcia enabled. I wait until the system is up, then
I do

/etc/init.d/pcmcia stop
/etc/init.d/hotplug stop

...takes some time...

/etc/init.d/pcmcia start
/etc/init.d/hotplug start

Works only in this order! I tried it several times, if
I start hotplug first, then pcmcia I get a "IRQ 11:
nobody cared" again.

It's a bit clumsy, but it works. I hope the next
kernel version fixes this.


___________________________________________________________ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

Reply to: