[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Building binaries for older versions of libc6

On Wed, Oct 20, 2004 at 02:58:16PM +0100, Ben Hutchings wrote:
> I have a C++ program which requires g++ 3.4 to build due to parser bugs 
> in older versions of g++.  I'm currently building on a development 
> machine running mostly woody with some packages from sarge, including 
> g++-3.4 of course.  This requires version 2.3.2 of libc6 itself, and any 
> binaries I build with it appear to require version 2.3.  Now, while I 
> prefer to do development on Debian, I need to build binaries that will 
> run on Red Hat Enterprise Linux 2.1, which has version 2.2.4 of libc6.
> I'm wondering whether it's possible to build binaries with g++ 3.4 that 
> will require only libc6 2.2, and if so, how.  If I remove g++-3.4, 
> downgrade to woody and then build and install g++ from source, is that 
> likely to work?

Yeah, but g++-3.4 will fail to link against any woody C++ libraries,
since those are built with g++-2.95.  If you only need libstdc++, you
should be OK.  Otherwise you'll need to rebuild all C++ libraries you
link against as well...

Blast you and your estrogenical treachery!

Reply to: