[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Thanks to both of you. I will try what you have suggested and get back.
In the meanwhile, yes, we do have a functioning debian on the machine. The problem is really with video driver/monitor settings. When I say "dpkg-reconfigure xserver-xwindows", it gives me various options. Depending on what video card I choose, xwindows either crashes (for example, if i choose i810) or gives a screen flickering in a peculiar way (e.g., when I choose vesa). I have not checked the errrors. I will do that today and try to figure out what I can.

BTW. I was trying installation on debian on two machines in a lab. Yesterday, I installed redhat on one of them because the machines could not have been spared for more days for experimenting. But I still have one machine with a functioning woody. Let me see where does that take me.

Thanks again,


Vikas Rawal wrote:

On (18/10/04 09:40), Paul E Condon wrote:
On Mon, Oct 18, 2004 at 12:39:47PM +0530, Vikas Rawal wrote:
> I have been trying to install debian on a Compaq Deskpro EN for last one > week. I have tried both woody (stable) and sarge (testing). In both, the > x-windows configuration does not work. In woody, installation went fine > except that none of the video cards/monitor options there get x-windows > running. I tried all sorts of options but no luck. > > Yesterday, I tried sarge. Sarge has to be installed using the > netinstall. That meant some 500 mb of download, took some 13 hours, and > at the end nothing worked. I think the problem is again with x-windows. > > What does one do? > > Vikas >
X-windows can be difficult. You probably have a working computer, except
for the x user interface. To test this theory, try a console screen by:

Press ctrl-alt-Fn where n is 1..6
You should see a login prompt.
Try logging in as root. If this succeeds, you do have a functioning, but
slight inconvenient, Debian installation.

Use it to investigate why x-windows doesn't work for you. Post any clues
that you don't understand, but be optimistic. You may be able to find
the problem yourself.

Try running 'startx'
Does this work?
Look for error messages if it doesn't. Probably, you have not installed all the x related packages that you
need. But which ones? The error messages should give you a clue.
Look at /var/log/XFree86.0.log

Where you see (EE) is where the problem lies



Reply to: