[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

GTK 1.2 font problems

The help in gnucash shows in a small, crummy font.  It's basically
unreadable.  Nothing I do seems to change it.  It looks OK in yelp.
I ordinarily run KDE on a testing system (though I tried Gnome too).

Judging by the dependencies, gnucash is a gtk 1.2 application.  I
assume yelp is good because it is a Gnome 2 (gtk 2?) app.

After reading the newsgroups, here's what I've tried:
1. In KDE, disable the setting (under color!) for controls appearance
of non-KDE apps.
2. Tried Gnome 2.
3. Created .gtkrc.mine in my home directory with
# Create by RB for gtk 1.2 in effort to make gnucash help look decent
style "user-font"
This file is included by .gtkrc-1.2-gnome2
4. Created .gtkrc-1.2, same as above.  (Nothing suggested this, but I
thought .gtkrc-1.2-gnome2 might only apply under gnome 2).
5. Added to .gtkrc-2.0
gtk-font-name = "Sans 12"
6. Tried
$ gnome-settings-daemon
You can only run one xsettings manager at a time; exiting

I did not log out before each attempt, though after doing these I did
start a Gnome session in a second virtual terminal.

Any other ideas?

P.S.  The previous operations did change my emacs fonts!

Reply to: