[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (Sid) Net broken - Sending streams stall

Executive summary:
KPPP is to blame, pon does not have the behaviour I described.

I knew older Debian's used to work, so I got out my old Potato CDs to see if 
this really was a problem with bad hardware disliking the Linux IP stack. My 
theory was that if it was bad hardware Potato would do the same weird things 
with file uploads.

I always used KPPP to dialup. I like to have the docked icon and throughput 
graph available. Of-course, my Potato CDs didn't come with KDE, so I went the 
way of the console, using pppconfig/pon/poff and cftp. They worked fine and 
all test uploads went smoothly, just as you would expect. No weird stalling 
of uploads that I had experienced, or that you would expect if there was bad 
hardware in the way. That made me wonder what was different. It was KPPP.

So I boot up Sid and try dialling by pon. Sure enough, uploads now worked 
flawlessly. (And I was able to commit a whole bunch of stuff that had been 
waiting for a month.) I hangup and try again in KPPP, and lo and behold 
uploads stall at 40K, just as it had been doing before.

So there you go - something is very wrong with my KPPP config (or KPPP 
itself). I'm not in a hurry to fix it now that I have a workaround, but any 
ideas are welcome. I'll post config files on demand. ;-)


PS: I'm subscribed, no more CC for me.

You wrote:
> On Fri, 27 Aug 2004, Brendon Higgins wrote:
> > I'd remember, but I don't remember doing anything regarding that
> > particular acronym. At least, not manually.
> A new kernel could have it enabled by default, or something...
> > Well, my computer can talk to any other, to a degree. For some reason
> > larger
> I mean through a router.  It certainly is having trouble.
> > data just fine, but seems to have trouble sending it. Mind you, this only
> > happens to individual streams, and it does not happen in Win98, which is
> > why I suspect something in my Debian install is broken. Does the Linux
> > TCP/IP implementation really differ that much from Windows that a problem
> > like this is possible to exist in one but not the other?
> Yes.  Linux TCP/IP is to Win98 TCP/IP what a P4 is to an original 80386SX.
> And there are a huge lot of completely buggy TCP/IP routers and firewalls
> out there, that fail to work right as soon as something that was not being
> done before is used.  Never mind TCP/IP is forward-compatible, when
> implemented correctly.
> Usually, it is Linux and the BSDs that hit those buggy routers first, since
> the Windows TCP/IP stack is something of the stone age that can barely talk
> to others.  When you only use the 5 most common words in a language, it
> gets difficult to find others that won't understand you...  But don't ask
> it to do anything too dificult.

Attachment: pgpd8L2zOXFI0.pgp
Description: PGP signature

Reply to: