[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mysterious X lockups on Sarge

On Tue, Aug 31, 2004 at 11:18:45AM -0700, Stefan O'Rear wrote:
> On Tue, Aug 31, 2004 at 02:26:12PM -0300, ScruLoose wrote:

> > For several weeks now, I've been having X lock up on me occasionally, 
> > and I'm a bit stumped as to where to start debugging it...
> > 
> > I'm running Sarge on a P4 3.2 HT, and my video card is a GeForce FX 
> > 5200 using the nvidia binary driver.  I've had this problem on both a 
> > home-rolled 2.4.22 kernel and the Debian 2.6.7-SMP kernel-package.
> Do you get the same problem with the generic VESA drivers? (no modules
> in the kernel, just Driver "vesa" - works for my SiS 315 even though
> they say it's unsupported)

Hm, haven't tried that yet... Maybe I'll run it for a while with XFree's 
"nv" driver instead, which IIRC supports the card but with no 3D 
In light of Hendrick having what looks like the same problem on a 
different brand of video card, however, this seems like a long shot.

> > Every couple of days or so X seems to die an abrupt death.  The display 
> > will freeze completely, keyboard input has no effect (including 
> > CTRL-ALT-F1 and CTRL-ALT-BACKSPACE).  The system is still running, 
> > though: If XMMS is playing when the problem hits, the music keeps on 
> > going; and I can ssh in to the box no problem.  If I kill -9 the XDM and 
> > /usr/X11R6/bin/X processes then the screen goes black... but then doing 
> > /etc/init.d/xdm start just silently fails.  So I've been ssh-ing in just 
> > to reboot the box.
> Try deleting the pidfile before restarting xdm. (/var/run/xdm.pid)
> Or perhaps just do sudo startx?

Deleting that pidfile made no visible difference.
ssh-ing in as my regular user and running startx produced some output 
that can be found at  http://shorty.ca/logs/startx.Xcrash.txt 

> > Now, I've had this happen while I was surfing the web, and while the 
> > screensaver was running, and sometimes after the monitor has gone to 
> > sleep (oh, and once in the middle of a game of armagetron).
> > 
> > A "tail" of XFree86.0.log shows a bunch of GetModeLine entries, but 
> > nothing that looks like error or panic or "ack! I'm dying!"...
> > I've done an 8-hr run of memtest86 with no complaints at all, the 
> > temperature seems to be happy, and loading the crap out of the system 
> > doesn't make it fail (I tried 5 hours of a kernel-compile loop, and 2 
> > hours of cpuburn with no problems).
> When you ssh in, does "dmesg" show anything abnormal?

Looks normal enough to my rather untrained eye, but here it is:

And just for the sake of argument, here's my XFree86 log after the 
latest crash:

        What sane person could live in this world and not be crazy?
        - Ursula K. LeGuin
--------------------------<<Please do not CC me>>--------------------------

Attachment: signature.asc
Description: Digital signature

Reply to: