[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: clock suddenly slipping behind

on Fri, 27 Aug 2004 02:21:44PM +1000, Tim Connors insinuated:
> Stefan O'Rear <stefanor@cox.net> said on Thu, 26 Aug 2004 20:34:17 -0700:
> > On Thu, Aug 26, 2004 at 11:23:07PM -0400, Nori Heikkinen wrote:
> > > over the past few days, i've noticed that my system clock gets about
> > > ten to fifteen minutes slow over the course of a day.  this is really
> > > weird!  i've been using ntpdate to synchronize it with a timeserver
> > > whenever i notice it, and i put it in a once-a-day cron job, but i
> > > want my system to ALWAYS be on time.  i'm confused as to what's
> > > causing this, and how i can fix it.  any ideas?
> > 
> > Perhaps your PIT is going south? (PIT = Programmable Interval Timer,
> > a variable-frequency timer usually set to 100HZ by Linux.)
> Nope. This seriously needs investigation.
> http://www.google.com/groups?selm=2qVhI-80D-5%40gated-at.bofh.it
> The one replyer said he didn't see anythign wrong.
> I had 2 machines with ntp packages and adjtimex querying two known
> good upstreams, plus three pool.ntp.org servers, that upon upgrade of
> sid a couple of weeks ago, broke at the rate of ~12 and ~14 seconds
> per 10 minutes (for my two machines, very constant for each), which
> was ~twice the rate that the OT reported).  One went through a kernel
> reboot and the other didn't, so it wasn't a new kernel issue.
> Uninstalling ntp and adjtimex and reinstalling didn't fix.
> Uninstalling, *purging* (so drift file and config files gone),
> *rebooting*, and then reinstalling fixed.  Doing one or the other of
> rebooting and purging was not good enough - the kernel keeps state in
> one case, and the ntp drift files etc keep state in the other case.

wait, uninstalling what, and purging what?  adjtime?

> I haven't tried to reproduce this, but things to note were the drift
> file *seemed* to have normal contents, the adjtime file was slightly
> off (but should only affect the hardware timer anyway, and was
> probably off because ntp was so confused - you can't calibrate the
> hardware clock off a faulty software clock).
> One other very clued in guy on the scary devil monastery also found
> this problem a day or two ago. I've been in communication with him,
> and it seems these are all related. There is a hard to trigger bug
> somewhere, but if you want to track it down, you'll prbablky need to
> reinstall old version of ntp and/or adjtimex and just keep working
> forwards and backwards until you trigger the bug again.

right now, i've got:

ii  ntp            4.2.0a-11
ii  ntp-simple     4.1.0-8
ii  ntpdate        4.2.0a-11
ii  adjtimex       1.18-1.1

did you get a set of versions that works for you?

and if this is a problem with these versions, should i file a bug?
hmm, this looks quite relevant:
(i'm also running kernel 2.4.26-1, like the submitter of this bug).

i'll try downgrading adjtimex to 1.13-1, the next lowest version in
the cache, and see if i still notice a drift at the end of the day (or
weekend ... i'll be gone until monday, so i'm not ignoring the thread
if i don't respond!)

thanks, as usual, for your help,


    .~.      nori @ sccs.swarthmore.edu
    /V\  http://www.sccs.swarthmore.edu/~nori
   // \\          @ maenad.net
  /(   )\       www.maenad.net/jnl
++     Sponsor me as I run my SECOND marathon for AIDS:       ++
++ http://www.aidsmarathon.com/participant.asp?runner=DC-2844 ++

Attachment: signature.asc
Description: Digital signature

Reply to: