[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trying to install to SATA drives on RAID 1



Hi folks,

Can anyone shed any light on this issue?  I'm a Red Hat refugee trying
to install Sarge, without much success so far.  I posted the message
below on debian-boot without any response.  I've also searched the
debian-user archives without result.

--------

My Debian installation saga continues.  I've just tried my fourth
different method.  My hardware is:

Gigabyte GA-7N400Pro m/b (nForce2 chipset)
Athlon XP 2400+
512 Mb DDR RAM
Silicon Image SI3112 onboard SATA, 2 x WD 200 Gb drives (target)
ITE IT8212F onboard ATA RAID, 2 x Seagate 80 Gb drives (Red Hat 9)
Standard ATA, 1 x Seagate 80 Gb drive
GF4 MX440 AGP 8x
2 x RTL-8139 NICs

This is what i've tried so far to install:

1.  Install via Sarge beta3/beta4/TC1/latest snapshot (using kernel
2.6), set up RAID devices.  Result: system lockup as soon as first md
device creation initiated.  noapic and nolapic directives made no
difference.

2.  Boot Morphix.  Create md devices and mount them on the appropriate
target directories, then run the morphix installer.  Upgrade and
downgrade and upgrade and downgrade until apt doesn't complain any more.
 Works OK, but doesn't give me a running 2.6 kernel, even after manual
installation - seems to be an issue with the NVIDIA proprietary drivers.
 Also slow due to pre-2.4.26 SI3112 driver.

3.  Install Libranet 2.8.1 - the least successful of the methods i've
tried so far.  It doesn't seem to support RAID in the installer, and
there doesn't seem to be a way to get the partitions mounted manually.

4.  Install latest Sarge snapshot to standard ATA drive.  Set up RAID
devices (md0 = 1 Gb /boot, md1 = 4 Gb swap, md2 = 195 Gb /), rsync ATA
partition to SATA partitions, chroot to target partitions and run LILO.

This last method seems to be on the verge of working, but when i boot
from the /boot partition, it can't mount md2 on /.  I can boot from the
SATA /boot and use the ATA /.  It seems the md devices aren't started,
and i can't work out how to include them in the initrd.  On RH, you
could just specify preload modules on the mkinitrd command line, but
that doesn't seem to be the case here.  I added raid1 and md to
/etc/mkinitrd/modules, but that doesn't help.  Any suggestions?
-- 
Paul
<http://paulgear.webhop.net>
--
Did you know?  Email is not private and can be viewed by your ISP, the
recipient's ISP, and possibly other parties.  You can make sure your
emails are private by using GNU Privacy Guard <http://www.gnupg.org> and
an email plug-in like Enigmail <http://enigmail.mozdev.org>.

Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: